Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After a fresh installation of Ubuntu 10.10 I tried to install build-essential from the Ubuntu installation CD. I put the cd in the cdrom and in the software repositories i checked the box install from cd(Ubuntu 10.10 release Maverick Meerkat).

Then I reloaded the software repositories. The synaptic manager then tried to download some repository related files but failed to do so as i didn't have internet connection. Then I open a terminal and wrote sudo apt-get install build-essential. It prompted me if I want to install build essential y/N. I typed y but the terminal showed some errors and was not installed. I also tried to add the CD in the software repositories.

I clicked add and it prompted me to insert a CD while the CD was still inside the cdrom. I clicked "ok" then and it showed it could not find any cd. What is wrong?

alt text

share|improve this question
add comment

2 Answers

You cannot install build-essential from the LiveCD disc because it is not on the disc - very few packages/programs are on the disc other than the default desktop (due to limited space on the CD)

If you can't connect to the interest you may like to have a look at How can I install software offline?

share|improve this answer
2  
But the packages related with Build-essential like g++, dpkg etc are on the cd /main/pool/..directory. I used to install it from the cd in the older versions of ubuntu like 9.10. I think it still there. –  munir Dec 27 '10 at 21:09
    
One other thing. why software repsitory prompted for a CD after i clicked add cd when a cd was still inside ? It said it could not find any CD the the cdrom. –  munir Dec 27 '10 at 21:13
    
In 8.10 i had to mount the cd in /media/cdrom or /cdrom editing the fstab file. But in this version the method does not work. I have noticed that if i check the checkbox of install from cd a folder named "apt" is created in the /media. and after "sudo apt-get install build-essential" command /media/apt/ is full with CD contents. –  munir Dec 27 '10 at 21:20
1  
Indeed, build-essential should be part of the ship seed contained in the installation CD. See Seed Management. –  Maxime R. Dec 28 '10 at 0:34
add comment

If you have no internet connection, remove (deselect) all repositories other than the CD. Perform an update and install again. This should install from the CD rather than the internet, and the only software that will be available will be that on the CD.

share|improve this answer
    
thank you for your answer. But This time "W: failed to fetch cdrom://Ubuntu....... file cannot be found....... " if i edit /etc/fstab file with "/dev/scd0/cdrom udf,iso9660 user,noauto,exec,utf8 0 0 " the cd is mounted in /cdrom/ then build-essential from the CD installs –  munir Dec 28 '10 at 18:38
    
Has anybody been successful installing any .deb file from the ubuntu installation CD without editing "fstab" file? By default no cd is mounted in /cdrom/. This kind of problem really upsets new users. –  munir Dec 28 '10 at 18:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.