Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just install Ubuntu to my P.C. I started it up with both my screens plugged into my nVidia's dvi and vga ports and logged in, change the skin to classic gnome, because that's how it was when I last used Ubuntu (8.1), and both screens were working separately.

The trouble is that I got a notification saying there was nVidia drivers to be installed, so I install them and restart my P.C., and when I get back on only one of my screens is working and when I go into Displays (All Settings, Displays) it doesn't register my other screen at all. It calls my working screen "Laptop".

I've tried looking through several pages of Google but I see no answer. I did try to find the nvidia-settings to see if that had the answers but sadly I couldn't locate it.

share|improve this question
add comment

1 Answer

I made a post about this over here Nvidia GTS 450 HDMI problem

But basically you need to use the Nvidia settings control panel not the default ubuntu control panel.

You also need to run it as root and then save the x configuration file.

It is pretty simple to do and I have it setup this way on my laptop with a RGB connector and it boots up and pops up from suspend perfectly so there is hope.

I am not sure how the old Gnome works with it since I use Unity, but I assume it is the same.

share|improve this answer
    
Hey, @Goddard thanks for the help, but when I config the X Server Display Configuration to how I want it and press "Save to X Configuration File" it gives me this error "Failed to parse existing X config file '/etc/X11/xorg.conf'!" –  user91396 Sep 19 '12 at 11:01
    
Thats because you need to run it as root. Try sudo nvidia-settings. I list all the details in my other post. –  Goddard Sep 19 '12 at 18:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.