Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have followed these instructions: https://help.ubuntu.com/12.04/serverguide/openldap-server.html#openldap-auth-config

The ldap server works fine. I can log into it using an ldap account.

However, I configured another Ubuntu 12.04 server as a ldap client for authentication but I cannot contact the server. Here is the error:

On the client:

# ldapsearch -Q -LLL -Y EXTERNAL -H ldapi://ldap01.domain.local -b cn=config dn
ldap_sasl_interactive_bind_s: Can't contact LDAP server (-1)

The server can receive requests:

On the client:

# telnet ldap01.domain.local 389
Trying 10.3.17.10...
Connected to sisn01.domain.local.
Escape character is '^]'.

On the client:

# ldapsearch -x -h ldap01.domain.local -b cn=config dn
# extended LDIF
#
# LDAPv3
# base <cn=config> with scope subtree
# filter: (objectclass=*)
# requesting: dn 
#

# search result
search: 2
result: 32 No such object

# numResponses: 1

On the server:

# ps aux | grep slapd
openldap  3759  0.0  0.2 564820  8228 ?        Ssl  08:39   0:00 /usr/sbin/slapd -h     ldap:/// ldapi:/// -g openldap -u openldap -F /etc/ldap/slapd.d

I suspect I am missing a configuration parameter either on the server or on the client. I just cannot figure out what. Any help here would be appreciated.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The url in your 1st ldapsearch is mangled.

Use either:

  1. for local socket ldapi:///
  2. for network url ldap://ldap01.domain.local
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.