Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installed Ubuntu 12.04 today and my problem is that when I'm moving the windows around my screen it doesn't feel smooth at all. Usually I can fix this by changing the refresh rate to 60Hz, but this time it doesn't help.

My graphics card is a Nvidia GTX 560Ti and I've tried both the 295.40, 295.45 and 304.43 (which I'm currently using) but neither has resolved my problem.

I searched around a bit and tried changing the refresh-rate using compizconfig-settings-manager and xrandr. No change using CCSM, but when I tried xrandr I got this reply:

konsolkongen@konsolkongen-desktop:~$ xrandr -r 60Rate 60.0 Hz not available for this size

- which is nonsense of course.

This is what my xorg.conf file looks like:

    # nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 295.33  (buildd@allspice)  Fri Mar 30 15:25:24 UTC 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 560 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP-0: 1680x1050_60 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Any help would be greatly appreciated, my obsession with video quality can't stand stuttering like this. For what it's worth though, I don't have any screen tearing, so at least V-sync is on.

Thanks.

share|improve this question
add comment

1 Answer 1

Same Problem here.

Changing nvidia driver helped (me too, I tried different ones), but none has really resolved the problem. It was terrible when freshly installed: The vertical window-borders acted like rerendering, while the horizontal lines moved more or less smoothly. Whit the nvidia-driver named below (and installed like the first link says), it solved half of the problem: the vertical flickering of the window-borders is gone, but the overall-feel is still a bit slaggy and sticky - far from being smooth. It's kind of strange: displaying HD-videos is smooth, while moving windows around is slaggy... I ended up using the 304.51-driver by updating the 295.49.

http://www.unixmen.com/201205-nvidea-295-49-has-been-released/

...if you feel like german, this site helped me a lot:

http://wiki.ubuntuusers.de/Grafikkarten/Nvidia/nvidia

lenovo t420 i7 ssd | ubuntu 12.04 32bit | nvidia card: NVS 4200m | nvidia driver: 304.51

edit: actually, here is what I did:

  • fresh install of ubuntu 12.04 32 bit
  • check (lenovos) bios-settings to be: display: "discrete" graphic and nvidia-optimus: "disabled"!
  • installing all proposed updates
  • installing nvidia-driver with:

    sudo apt-add-repository ppa:ubuntu-x-swat/x-updates 
    sudo apt-get update 
    sudo apt-get install nvidia-current
    
  • no(!) activation of the nvidia-driver via additional drivers (this killed my system)

  • looking at my xorg.conf file (there nvidia is already correctly listed as the active driver in use)

that's all, it removed the flickering (while I still wait for the final smoothness...)

Hope it helped.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.