Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to use the open source Radeon driver for Ubuntu, but currently I'm using fglrx.

So, I went ahead and purged fglrx using sudo apt-get remove --purge fglrx* and when I rebooted and ran sudo lshw -c video, I still see driver=fglrx_pci. I've followed the instructions here.

I'm not sure why I can't completely purge fglrx, is anyone else experiencing this? I also checked Synaptic Package Manager and Additional Drivers and it says I'm not using fglrx at all. I'm not sure if I'm really using fglrx now.

Have anyone else encountered this? Thanks.

share|improve this question
    
ehh i am not completely sure about the command u used. I always use this sudo apt-get purge fglrx* –  blade19899 Sep 18 '12 at 14:12
    
also tried running that, but still same result. –  mumble Sep 18 '12 at 14:17
    
Did u tried via GUI: system settings> Driver –  blade19899 Sep 18 '12 at 14:32
    
Yup, it says I don't use fglrx anymore. –  mumble Sep 18 '12 at 14:37
add comment

1 Answer

up vote 2 down vote accepted

Try to blacklist this driver. Issue this command as root:
echo "blacklist fglrx_pci" >> /etc/modprobe.d/blacklist-fglrx_pci.conf

Reboot.

share|improve this answer
    
Hmm..it says 'bash: /etc/modprobe.d/blacklist-fglrx_pci.conf: Permission denied', even with sudo. –  mumble Sep 18 '12 at 14:16
    
Issue sudo su before, after that issue my command. –  Frantique Sep 18 '12 at 14:19
    
I've tried that, but still the same error. –  mumble Sep 18 '12 at 14:28
1  
I used vim instead and added the blacklist fglrx_pci line, worked great. Now using the radeon driver, thanks! –  mumble Sep 18 '12 at 14:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.