Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just bought this notebook and I've already installed in a new partition Ubuntu 12.04 LTS with 6GB of swap memory.


This is the laptop configuration:

Sometimes (without any special conditions) Ubuntu freezes. My mouse is blocked, the UI is blocked, Alt+F1 to kill something or to restart is blocked, I can't really do anything...

I've also tried and it freezes with:

  • Ubuntu 3D
  • Ubuntu 2D
  • GNOME Shell

and it freezes both with low and high load.

I can only press the power button (physically) and restart my laptop (and this is not the correct way to do things). I'm using this laptop for work, so I need a stable OS without this freeze.

Someone knows how to solve this problem?


I just installed the proprietary driver from ATI, but it crashes anyway. This morning I started the laptop, I enabled wireless, opened Dropbox and Chrome -> freeze.

When it freezes I cannot:

  • Do Ctrl+Alt+F1 to get console access
  • Alt+F2 + r to reload session
  • Alt+Print Screen + RESUB to restart

It is totally frozen.

share|improve this question
I'd suggest posting the system logs (/var/log/messages, /var/log/kern.log, /var/log/Xorg.0.log) using paste. – January Sep 21 '12 at 14:40
Duplicate of… ? – fossfreedom Sep 21 '12 at 14:41
@fossfreedom not really, since he wants to solve a particular problem with a particular machine. Maybe someone who has the same laptop will see the question and posts a specific reply. – January Sep 21 '12 at 14:43
@January updated with logs, hope it helps – StErMi Sep 22 '12 at 9:38
Have you done any kernel updates recently ? Try different kernel version from "Previous Linux versions" in GRUB menu. – dixoncx Sep 22 '12 at 19:14

@StErMi, the errors below can be related to your problem.

[FIRMWARE BUG] ACPI(PEGP) defines _DOD but not _DOS

[Firmware Bug]: Invalid critical threshold (0)

drm:intel_dsm_platform_mux_info] *ERROR* MUX INFO call failed

According to this, using the acpi_backlight=vendor option will solve first bug. If this does not work, you can try the acpi=noirq option.

For the second bug, it is recommended to make a BIOS update and you can see that BIOS update solved the problem.

For the third one, one workaround is to use the pci=noapci option, but if you use this option you will not be able to use the ATI graphics card.

I know these will not permanently solve your problem but at least there is hope that one of the workarounds could provide a usable Ubuntu for you.

To use the options that are mentioned here, look at this link.

share|improve this answer
if those changes will fix my freeze, how can I share my solution in order to set by default those options in fresh installations? Anyway I will try to do as you said and I will update (and change as correct answer) in a few days of testing. Also, from Windows I launched HP Help that automatically update bios. Is it really updating bios or have I to do it manually? – StErMi Sep 22 '12 at 11:52
As I said I'm using Ubuntu only to develop, so I don't need to have the ATI enabled, I think that integrated VGA can handle Unity3D animations right? So I can enable pci=noapc, am I correct? – StErMi Sep 22 '12 at 12:10
acpi_backlight=vendor has not worked (it freezed again). Now I will try to use acpi=noirq. Have I to use both or only the latest? – StErMi Sep 24 '12 at 10:23
also acpi=noirq wont solve the problem, it has just freezed :( now I'll try to add pci=noapci to grub config – StErMi Sep 26 '12 at 8:23
Sorry, all those options have not solved my problem :( – StErMi Sep 28 '12 at 13:00

I had a random freeze problem with my new Lenovo T430s as well (i7-3520M). It was between once-a-week and 3-times-a-day.

Somewhere on the Internet I've found indications that this might be an Ivy Bridge graphics causing the freeze.

Then I updated to 12.10 alpha and problem has vanished.

Could it be the same problem despite you are using AMD/ATI graphic card?

share|improve this answer
I thought so, I started install of 12.10 and it freezed, so everything was broken. I tried to install from USBStick a fresh 12.10 but it wont start, so I'm still stuck on 12.04 with these freezes :( I will wait for official release of 12.10 on end of October – StErMi Sep 28 '12 at 13:01
up vote 0 down vote accepted

I think that the solution is to upgrade the current kernel to version 3.x this seems to have solved my problem. In this Article I understand that I've the same problem of that user (Ivy Bridge bug).


sudo add-apt-repository ppa:upubuntu-com/kernel
sudo apt-get update

For 32bit users

sudo apt-get install linux-kernel

For 64bit users

sudo apt-get install linux-kernel-64
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.