Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed ggobi on my MacBook Pro, and it wasn't working right. I looked up some information, and found this site: Gtk Warning: Cannot open display

I followed the vague instructions, but I think I just typed export DISPLAY=:0 directly into my terminal (I'm still in my Mac partition at this point).

Fast forward a few days, and I try to go into my Ubuntu partition. It only gives me command line options. I remember my reckless input from a few days back, and I'm certain that it is the issue.

My problem is that I have no idea how to get my previous display settings back. My Mac partition seems unaffected, but it'd be nice to get back into my Ubuntu partition.

My last resort is completely reverting my computer to my most recent backup before I changed it, but if anyone out there knows how to fix this, I'd greatly appreciate it.

Thanks in advance.

share|improve this question
This input has nothing to do with partitions. It's forcing a program to display on a certain monitor. – hexafraction Sep 18 '12 at 22:55
I didn't specify a program when I put in 'export DISPLAY=:0', so it's not specific to any program. Even if it's not the cause, what else would have changed my Ubuntu partition so that I can only interact with it via text? When I try to launch a program, various errors pop up involving 'DISPLAY', so I'm almost certain this command is the cause. – Danny Sep 18 '12 at 23:30

It sounds like X is not starting; setting the DISPLAY won't do anything, because there isn't an actual display running.

See if you can start in Failsafe X mode:

  1. Boot into the recovery console
  2. Choose Failsafe X mode

That will at least get you back to X where it's comfy.

Have a look at/post your Xorg log. It's at /var/log/Xorg.0.log, especially for lines marked "(EE)" for error.

Also look at/post your /etc/X11/Xorg.conf file, the Xorg configuration. Usually you can safely delete/move this file, and it will automatically be regenerated with good defaults.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.