Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using the display program I cannot detect the second display which is connected with my desktop PC (running ubuntu 11.10 64bit, gtx 280 gpu) via DVI.
Although using a live CD of linux mint the second screen was used when it loaded, without me having to set anything else.

What can I do?

Thank you for your time!

share|improve this question
    
Are you using Nvidia's binary drivers or Nouveau? If it's the binary driver, then install and run nvidia-settings to configure your display (hit the Detect Displays button on the X Screen configuration and set up TwinView if you like Dual-Head display). And, any reason for running Ubuntu 11.10 now? –  gertvdijk Sep 17 '12 at 22:31
    
@gertvdijk: I am using nvidia's binary drivers. I've set up the separate x screen but it didn't work as expected..After a logout and login,my main monitor became white and the 2nd monitor became main (where the login manager showed up and where unity appeared). Why shouldn't I use 11.10? I am expecting for 12.10, to upgrade..I might upgrade it to 12.04 (i just didn't have the time) –  Chris Sep 17 '12 at 22:47
    
Usually you don't want to use separate X Screens. Try TwinView as I already proposed. Please include more related information like drivers your installed in your question next time. –  gertvdijk Sep 17 '12 at 22:57

1 Answer 1

Because you are using Nvidia's binary driver, try configuring your screen using Nvidia's settings utility (nvidia-settings - both executable name and package name).

For dual screen 'extending screen' configurations set the Configuration to TwinView, like this:

NVIDIA Settings dialog

You may need to re-trigger the detection of just connected displays by hitting the Detect Displays button.

Don't forget to Save to X Configuration File if you like to keep your settings persistent across reboots. You may need to run nvidia-settings with root privileges by prepending the command with sudo or gksu.

share|improve this answer
    
I did as you said but now the launcher is at the 15" monitor and I want it to be at the 23" monitor. The order of my monitors on my desk is: left 15", right 23". I want to keep that order with the twinview configuration. Is there any way to display the unity launcher at the 23" screen? –  Chris Sep 17 '12 at 23:16
    
Did you try to tick the Make this the primary display for the X screen checkbox for the screen you want to run your launcher on? –  gertvdijk Sep 17 '12 at 23:26
    
Yes, it is checked for the 23" monitor but the unity launcher appears at the 15" one. –  Chris Sep 17 '12 at 23:31
    
@Chris I guess you're hitting a bug somewhere. Try asking a new question, targeted to your (new) issue. –  gertvdijk Sep 17 '12 at 23:33
    
This is what I am seeing now. Posted it just to make sure that I've have the correct settings and not getting the correct result. –  Chris Sep 17 '12 at 23:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.