Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Kmail: "sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)")

What can I do? Someone who knows how to setup kmail correctly? Nor automatic or hand procedure works.

share|improve this question

1 Answer 1

This is not an error of KMail, but from the remote SMTP server it is talking to.

The server (MTA) is complaining about your request. Probably you are trying to send mail and using an SMTP server which does not allow relaying in your current configuration.

Some general solutions to this:

  • Configure SMTP authentication according to the manual of your hosting or freemail provider. Try to find some information like "mail client configuration settings". If it's about a corporate mail server: ask your system administrator for SMTP settings for use in your mail client. Use this information to configure your account in KMail.
    If authenticated to the SMTP server you may have the privileges to get mail relayed out.
  • Configure KMail to use your ISP's SMTP relay server. Most ISPs are running one, for example listening to the name smtp.ispname.tld.
    However, when using another ISPs connection you cannot use the same server, but you'll have to reconfigure it according to use the one of the other ISP. Therefore, the option above is recommended for mobile PCs and should work throughout all networks.
  • Try to use Thunderbird's initial configuration wizard. It's quite good at guessing the right configuration options. If that works out, read the configuration in Thunderbird and set the same options in KMail.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.