Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this type of error when starting XAMPP:

Starting XAMPP for Linux 1.7.7...
XAMPP: Another web server daemon is already running.
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: Another FTP daemon is already running.
XAMPP for Linux started.

How can be it solved?? Can any one help me please?

share|improve this question
2  
Hello. Welcome to Askubuntu. The details on your question isn't having any sense. Please provide enough information about the steps that you are following, your current Linux Distro/Version, and if possible a link of where are you getting the steps that is causing your issue. Additionally, it will really help us if you say what are you trying to achieve in order to understand what are the problem itself and provide the proper support. Good luck! –  Geppettvs D'Constanzo Sep 17 '12 at 18:37
    
i am currently using ubuntu 11.04. i had install xampp and i had this problem can u help me plz? –  Drudge Sep 17 '12 at 18:43
1  
I don't see what the problem is with the downvotes and confusion. Seems clear to me. I don't use XAMPP, but I run each server separately. MySQL and Apache web server are already running, and perhaps the FTP server, and XAMPP is trying to start them again, it seems. Did you install MySQL and Apache before (or after) XAMPP? Or maybe trying to start XAMPP twice? If so, I may be able to help sort it out for you. –  Marty Fried Sep 17 '12 at 18:46
1  
I am with you @MartyFried. I was just giving an advice for making a better question and obtaining better support, other than "downvotes". BTW, I upvoted, so the user91144 will be able to respond/edit. Me myself can't understand the Askubuntu user's behavior but so they are. And we are here to provide help and support. Not to downvote people aiming them to leave the forum. Thanks and good luck! –  Geppettvs D'Constanzo Sep 17 '12 at 18:52
    
i had install xampp and when i saw this problem i unisntall and reinstall it many time bt the result is same what to do? –  Drudge Sep 17 '12 at 18:53
show 4 more comments

1 Answer 1

XAMPP is a package of several programs like a webserver (Apache), a database server (MySQL) and others. With many of these programs, you can only run one instance at the same time. So if you for example have a webserver running, you cannot start another webserver until you stopped the first one. The same goes for the MySQL server, the FTP server and others. (Technically, you can start several webservers etc. if each of them uses a different port, but I assume you'd want to stick with the standard ports for the beginning).

The error messages you provided indicate that when you try to start XAMPP, there already is a webserver, a MySQL server and a FTP server running. So XAMPP can't start an additional webserver, MySQL server or FTP server. So you need to figure out if those servers are actually there, where they came from and if you want to use them or the XAMPP versions.

The first test is to point a webbrowser (Firefox, Chrome, Opera, ...) to your local computer without trying to start XAMPP and to check if anything answers. So point your webbrowser to http://localhost. If a website appears, maybe the default "It works!" page from Apache, there is already a webserver running and XAMPP can't start an additional one. You can do similar tests with MySQL, the FTP server and the other components of XAMPP.

If there is actually a webserver running before you try to start XAMPP, you need to find out where it came from. I see two possibilites: XAMPP is already running, maybe it's tarted automatically at boot time, or the "standard" packages of Apache, MySQL etc. are installed and running. There are several ways to check that, one is to temporarely change a detail in the HTML files that one webserver is supposed to deliver. If you for example add a word, say "TEST", to the HTML that XAMPPs Apache is supposed to deliver, you can see whether that change appears in the browser or not. You can go on from there.

share|improve this answer
    
yep bro again i had remove and install the xampp. when i start the xampp i had the same problem bt when i stop the xampp services then also i can see this page("localhost/xampp/splash.php") in my browser how can i solve this plz help me bro!!! –  Drudge Sep 19 '12 at 5:44
    
So the splash.php file is located in your XAMPP installation? In that case I would assume that XAMPP gets started automatically when you start your computer, so you don't need to start it manually. –  Henning Kockerbeck Sep 19 '12 at 12:10
    
no when i try to open localhost frm my browser when my pc starts then it i get nothing ?? what is the main problem ?? can u help me plz?? –  Drudge Sep 22 '12 at 16:16
    
That's odd. XAMPP complains that there already is a webserver running when it tries to start its own webserver, but there is no webserver running? Maybe you try to start XAMPP twice? But it's just guessing on my part now, sorry. –  Henning Kockerbeck Sep 25 '12 at 14:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.