Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to install Acrobat Reader on my Ubuntu 12.04.1. In the be;ggining, I tried to install it from the software-center, but it crashes with the report:

(Reading database ... 189311 files and directories currently installed.)
Unpacking acroread (from .../acroread_9.5.1-1precise1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/acroread_9.5.1-1precise1_i386.deb (--unpack):
 trying to overwrite '/usr/bin/acroread', which is also in package adobereader-ptb 8.1.7-2
No apport report written because MaxReports is reached already
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/acroread_9.5.1-1precise1_i386.deb"

As as solution, I tried to install it via terminal, with the

$sudo apt-get install acroread

and receive the following:

arcanjo@arcanjo:~$ sudo apt-get install acroread
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Pacotes sugeridos:
  libldap2 libgnome-speech7
Os NOVOS pacotes a seguir serão instalados:
  acroread
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 60,1 MB de arquivos.
Depois desta operação, 142 MB adicionais de espaço em disco serão usados.
Obter:1 http://archive.canonical.com/ubuntu/ precise/partner acroread i386 9.5.1-1precise1 [60,1 MB]
Baixados 60,1 MB em 4min 17s (234 kB/s)                                        
(Lendo banco de dados ... 189311 ficheiros e directórios actualmente instalados.)
Desempacotando acroread (de .../acroread_9.5.1-1precise1_i386.deb) ...
dpkg: erro processando /var/cache/apt/archives/acroread_9.5.1-1precise1_i386.deb (--unpack):
 a tentar sobre-escrever '/usr/bin/acroread', que também está no pacote adobereader-ptb 8.1.7-2
Nenhum relatório apport escrito pois MaxReports já foi atingido
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processando gatilhos para gnome-menus ...
Processando gatilhos para man-db ...
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/acroread_9.5.1-1precise1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
arcanjo@arcanjo:~$

I've already tried to upgrade and update the apt-get, also tried to remove and re-install the software-center, tried deleting the "problematic" files and re-updating the apt-get... Nothing seems to work... Any solutions?

share|improve this question
4  
This isn't an answer to your question, but it is recommended to not install adobes reader since it is bloated and a security risk. If you use Chrome it comes with its own built in PDF reader and Evince is good for the desktop and comes default. Any reason you need the Adobe version? –  Goddard Sep 17 '12 at 18:21
    
Looks like you have a conflict with the package adobereader-ptb. Try to remove it by sudo apt-get remove adobereader-ptb and try to install acroread again. The remove will show you if it removes packages that depend on adobereader-ptb. This way you can see why it was installed. Make sure it doesn't remove anything you still need. –  André Stannek Sep 17 '12 at 18:42
    
@Goddard I try to avoid the Acrobat Reader if possible, but sometimes I have documents that only work with Acrobat (Mostly forms with text fields to fill in). +1 anyway :-) –  André Stannek Sep 17 '12 at 18:45
    
Have you tried the Google Docs extension for your browser? –  Goddard Sep 17 '12 at 19:06
    
Nope, will try it next time. Thanks! –  André Stannek Sep 17 '12 at 19:10
show 1 more comment

1 Answer 1

open your terminal and type this one by one

sudo dpkg -r acroread_9.5.1-1precise1_i386.deb
sudo apt-get -f install
sudo apt-get update
sudo apt-get upgrade
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.