Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the latest Ubuntu version. When I try to open a .wmv file I got the error :

Required plugin could not be found.
Python (v2.7) requires to install plugins to play media files of the following type: video/x-asf-unknown decoder

What can I do to fix it?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

It seems the video is using GoToMeeting codec which is not supported on Linux. I searched the Internet and found this forum thread.

There was a link to this page which was provided to be helpful. I read it, as far as I understand, you need to have Wine, mplayer, w32codecs and gotomeeting codec to play it via Wine

I'm quoting the text below:

If you want to watch a GoToMeeting video on Linux (g2m3 codec) You'll need to install mplayer, win32 codecs, wine, the gotomeeting codec (copy the G2M.dll codec to /usr/lib/codecs). Then run the video with WMV. You also might want to see this post on downloading the g2m3 codec.

Apparently, The process is as follows:

  1. Install Wine with sudo apt-get install wine

  2. Install mplayer with sudo apt-get install mplayer. You may want to install a front-end for mplayer. Try smplayer with sudo apt-get install smplayer

  3. Enable the medibuntu repository by going to this help page.

  4. After adding it, install w32codecs with sudo apt-get install w32codecs.

  5. Then Download the free gotoMeeting codec from here. Install the downloaded .exe file with Wine.

  6. After installation, try to play the file using smplayer or mplayer.

    Don't forget to copy the G2M.dll file which is installed via Wine into /usr/lib/codecs directory. Most probably, you will find that file under .wine directory which is hidden in your home directory. You can search for that file using nautilus search feature.

For further info, you may want to visit these links:

Hope this answer will help.

share|improve this answer
    
Thank you so much! –  Vagelism Sep 20 '12 at 15:32
    
@Vagelism glad to help. Please leave a feedback whether it works :) –  Anwar Shah Sep 20 '12 at 15:37
    
yes...I forgot. –  Vagelism Sep 21 '12 at 19:07
    
When I try to install the gotoMeeting codec, I get: "Could not get Program Files folder" –  vishvAs vAsuki Jul 8 '13 at 23:22

You need the right codecs to play .wmv wich are windows movie i believe. Try running the following in a console:

sudo apt-get install ubuntu-restricted-extras

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.