Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I had issues with WiFi so I removed Network Manager.

I booted Windows OS (dual booting Windows 7 and 12.04) to download wicd Extracted it and installed. However, wcid worked properly with Wired Connection but could not connect to WiFi. So, I re-installed Network Manager which works properly now, and wicd connects to WiFi too.

As soon as I disconnect from Network Manager, wicd connects only to wired. At this point, I wanted to remove wicd but apt-get returns no wicd installed, can't see it in Synaptic or Software Center, but only in Applications list under Dash home.

Of course wcid icon shows connections, and resulting connected, so my system shows both applets for wicd and network manager in the top panel. When running dpkg commands, wicd is not listed as installed package.

Any suggestion how to remove wicd? Consider that I started with Ubuntu just few months ago so my knowledge base is limited.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

have you installed it from source? you can't use synaptic or software center to remove wicd then.

By the way, you should look for a startup script, to remove wicd from startup. Then you will not need to uninstall, it won't get started if you remove it. Check /etc/rc5.d and /etc/xdg/autostart for entries. (I assume you boot to gui)

share|improve this answer
Thanks g_kaya, ur reply made me think and i come to a solution, i removed it from start-up applications, then installed wicd and uninstalled it using terminal, then manually removed files i had downloaded. NM works nice now :) and wicd completely removed :) –  danijelc Sep 17 '12 at 20:20
You're welcome :) Glad you solved your problem. –  user91091 Sep 18 '12 at 13:13

Since I also had problems with Wicd + NetworkManager, it had to be decided which one will disappear from the OS, as it seems both interfaces do a sloppy job when it comes to deal with dependencies and side effects.

First I decided to remove Wicd, and that should match your question (then I tried Wicd without NM, but that's another story...).

Normally, if installed from a package (apt-get), the line

sudo apt-get purge wicd

should be enough. If not, and installed from the source, there is a in wicd-dir/ source code dir that should fix the uninstallation. If not...

  1. the theory wants that editing


and set START_DAEMON=no would be enough of a job to just stop the process and family from starting. But it's not enough. So... when a program is tied to several places that don't rely on a single config file, I remove it completely: (it's also linked to my own gnome configuration, and yours may vary)

  1. ensure the init program does not run

That's basically in /etc/rcX.d. All the S20wicd can be renamed K00wicd automatically, thanks to a script like rcconf.

And now remove the crumbs...

  1. move the desktop autostart stuff

Something like

mv /etc/xdg/autostart/wicd-tray.desktop /etc/xdg/wicd-tray.desktop.donotstart
  1. dbus

Similar to the above

mv /etc/dbus-1/system.d/wicd.conf /etc/dbus-1/wicd.conf.donotstart

And reboot, wicd should be quieter.

Again depending on your settings, the files could be somewhere else in /etc.
Do a find /etc -iname "*wicd*" to find where they're likely to sit.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.