Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had issues with WiFi so I removed Network Manager.

I booted Windows OS (dual booting Windows 7 and 12.04) to download wicd 1.7.2.4. Extracted it and installed. However, wcid worked properly with Wired Connection but could not connect to WiFi. So, I re-installed Network Manager which works properly now, and wicd connects to WiFi too.

As soon as I disconnect from Network Manager, wicd connects only to wired. At this point, I wanted to remove wicd but apt-get returns no wicd installed, can't see it in Synaptic or Software Center, but only in Applications list under Dash home.

Of course wcid icon shows connections, and resulting connected, so my system shows both applets for wicd and network manager in the top panel. When running dpkg commands, wicd is not listed as installed package.

Any suggestion how to remove wicd? Consider that I started with Ubuntu just few months ago so my knowledge base is limited.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

have you installed it from source? you can't use synaptic or software center to remove wicd then.

By the way, you should look for a startup script, to remove wicd from startup. Then you will not need to uninstall, it won't get started if you remove it. Check /etc/rc5.d and /etc/xdg/autostart for entries. (I assume you boot to gui)

share|improve this answer
    
Thanks g_kaya, ur reply made me think and i come to a solution, i removed it from start-up applications, then installed wicd and uninstalled it using terminal, then manually removed files i had downloaded. NM works nice now :) and wicd completely removed :) –  danijelc Sep 17 '12 at 20:20
    
You're welcome :) Glad you solved your problem. –  cadadr Sep 18 '12 at 13:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.