Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is driving me crazy. I'm using monochrome rendering for fonts and this causes a few problems in my browser so I wanted to make Ubuntu the standard sans-serif font. I changed it in the preferences and it initially works okay but after a while it reverts to the default. If I go into the font section in the menu, it still lists Ubuntu and if I click OK the pages will correct themselves. Does anyone know I can stop this behaviour?

I'm using Opera 11 on Ubuntu 10.10

share|improve this question
8  
You should file a bug report at bugs.opera.com/wizard . –  João Pinto Dec 27 '10 at 11:16
1  
Thanks for the link, I've done as suggested. I also asked on the Opera forums, but wanted to ask Ubuntu as well since the community support is so good. –  Roddie Dec 27 '10 at 11:30
1  
Did you change the font in the section "Preference -> Web pages" or in the section "Preferences -> Advanced -> Font". To get the font work correctly I had to chage everything subsection of the latter one. Also did you try to use dragonfly (rigth click then "inspect element") on a webpage that doesn't display correctly to see where opera look for the font (i.e. in user css, or the webpage css). Finally, are you in author mode or in user mode (in page-> style), the behaviour change totally depending on which mode you use. –  Noz Dec 27 '10 at 16:56
1  
Have you tried this? : In page -> style -> edit modes, check the box "my font and colour" and maybe uncheck the box "font and colour of the page" in the user mode column. This will probably override any font entries on the webpage you visit however. (The path to the thing maybe wrong because I'm translating from my french version of Opera). –  Noz Dec 27 '10 at 18:55
1  
Sorry, just realised the default is author mode, so that's what I've been using. I've played about with the settings for author and user modes but, as you mentioned, I don't want to override fonts on all websites. –  Roddie Dec 27 '10 at 22:19

2 Answers 2

up vote 3 down vote accepted

This is not an Ubuntu issue but rather an Opera bug and apparently it's been present since version 10.60 of the browser. It has been raised as such with the Opera team (the ID is DSK-324216) but as there has been no movement in nearly a year since reporting it, I'm not too hopeful of it ever being fixed.

I discovered a workaround which involves creating a .css file in ~/.opera/styles/user and populating it with:

pre, code {
    font-family: "Ubuntu", sans-serif;
}

You can then select this file in Preferences > Advanced > Content > Style Options... > My style sheet.

share|improve this answer

Well, it seems than even in v12.00 Next, this bug is not fixed in Opera. The only thing we can do is: wait...

For this reasons, I love Launchpad.net and open source development. It’s always nice to follow progress of your bugs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.