Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ever since I printed a document from Evince in landscape orientation, LibreOffice Calc / Writer refuses to print anything correctly. It is scaling everything by 0.5x and rotating it. To get the same effect, go to print -> page layout tab -> pages per sheet = 2. However, I don't want 2. I want 1.

I have wizzed through all of the printing options a few times but can't get to the bottom of this. I've restarted my printer and computer several times. I have done sudo apt-get purge libreoffice* and reinstalled again. Still it will not print full size.

(Of course I have checked that the page settings are set to A4 and portrait.)

Update: this problem is specific to one printer only, to printing from within LibreOffice (Calc, Writer). With other printers / programs I have no problems.

share|improve this question

closed as too localized by Tom Brossman, Eliah Kagan, hexafraction, Jjed, Jorge Castro Oct 3 '12 at 0:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What happens if you print from other applications (Browser, LibreOffice Writer, Gnumeric, gedit or anything else)? Which ubuntu version are you using? 12.04? –  tohuwawohu Sep 17 '12 at 10:53
    
Thanks for the comment! All other applications are fine. (For the moment I am doing export to pdf and then printing from evince = works.) I can confirm this is not just Calc - Writer is also doing the same. –  oldmankit Sep 18 '12 at 3:34
    
I'm at a loss to fix this! I have done sudo apt-get purge libreoffice* and reinstalled, and printed a brand new document. It still prints everything half size. This time a two page landscape document gets printed to fit exactly onto one A4 portrait piece of paper :-/ –  oldmankit Sep 25 '12 at 10:32
1  
This is an obvious one but I'll post it in the interest of being thorough: Print/Page Layout(tab)/Pages per sheet should be set to 1. –  Tom Brossman Sep 25 '12 at 11:01
1  
Can you delete ~/.config/evince (copy to your desktop if you want a backup) and try again? I suspect this has more to do with evince than LibreOffice or the printer. Open your home folder in Nautilus and press Ctrl + H to show hidden files which will reveal the .config folder. –  Tom Brossman Oct 2 '12 at 8:53

2 Answers 2

up vote 1 down vote accepted

Solved: deleted offending printer and reinstalled. Now everything is now working OK.

I still have no idea what went wrong though...

share|improve this answer

I've searched and tried a lot of solutions for that and found only one that works. To print document in landscape you have to create Lanscape style.

Go to Format - Styles and Formatting

Then go to tab Page Styles. Right click and select New.

Create new style, (named for example "Landscape"), under Page tab select paper format and most important Landscape orientation. Turn off/on Header and footer by will. Save it and activate Page Style by double-click on it (in my case Landscape). File Print.. and voila! To go back to regular portrait print just double-click Default Page Style under Styles and Formatting.

share|improve this answer
    
Hi @alen-t, thanks for the answer. But I'm not trying to print landscape! –  oldmankit Oct 2 '12 at 8:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.