Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to upgrade linux-image-3.0.0-26-generic I get following problems:

dpkg-deb (subprocess): data: internal bzip2 read error: 'DATA_ERROR'
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing /var/cache/apt/archives/linux-image-3.0.0-26-generic_3.0.0-26.42_amd64.deb (--unpack):
 short read on buffer copy for backend dpkg-deb during `./lib/modules/3.0.0-26-generic/kernel/drivers/scsi/fnic/fnic.ko'
No apport report written because MaxReports is reached already
                                                              Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.0.0-26-generic /boot/vmlinuz-3.0.0-26-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.0.0-26-generic /boot/vmlinuz-3.0.0-26-generic
Errors were encountered while processing:
 /var/cache/apt/archives/linux-image-3.0.0-26-generic_3.0.0-26.42_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:

dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-3.0.0-26-generic; however:
  Package linux-image-3.0.0-26-generic is not installed.

I don't know why this happens to me; earlier upgrades always worked without problems.

Does anybody know how to fix this?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I think the .deb package is corrupt, see this article for further explanation.

Solution:

apt-get clean # clears out the local repository of retrieved package files
share|improve this answer
    
Thank you! You were exactly right. Now it works like a breeze :) –  Dan Lee Sep 17 '12 at 9:37
add comment

try this sudo apt-get install linux-image-TABTAB

it will show you all the possible kernel image which will support your system

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.