Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 10.04 on my PC with IP 192.168.1.101. every thing work fine, e.g. my web server is running and I can see http://localhost/ or http://192.168.1.101 properly.

But the problem is that I cannot see my PC from my laptop at 192.168.1.102 e.g. at my laptop http://192.168.1.101 gives Connection timed out in browser. or trying to telnet on any port leads to:

telnet: Unable to connect to remote host: Connection timed out

laptop is running a fresh install of Ubuntu as well and there is no setup for firewall stuff in both computers.

PS:

  • Both computers can ping each other well.

  • The router is a cicso linksys wireless ADSL modem.

  • Currently, I can connect to FTP server on the Windows running on 192.168.1.102 from 192.168.1.101 without problem.

  • I tested the address http://192.168.1.101 with my friends' laptops (They use Windows 7 and XP). both received "Connection was reset". It differs with my laptop's response.

  • Theses are commands ran on my PC, 192.168.1.101:

ifconfig:

adp@adp-desktop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:26:18:e1:8e:cf  
          inet addr:192.168.1.101  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe70::226:18ff:fee1:8ecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1831935 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1493786 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1996855925 (1.9 GB)  TX bytes:215288238 (215.2 MB)
          Interrupt:27 Base address:0xa000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:951742 errors:0 dropped:0 overruns:0 frame:0
          TX packets:951742 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:494351095 (494.3 MB)  TX bytes:494351095 (494.3 MB)

vmnet1    Link encap:Ethernet  HWaddr 00:50:46:c0:00:01  
          inet addr:192.168.91.1  Bcast:192.168.91.255  Mask:255.255.255.0
          inet6 addr: fe70::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vmnet8    Link encap:Ethernet  HWaddr 00:50:46:c0:00:08  
          inet addr:192.168.156.1  Bcast:192.168.156.255  Mask:255.255.255.0
          inet6 addr: fe70::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:51 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

port 80 is set to 0.0.0.0 well:

adp@adp-desktop:~$ netstat -ln | grep 'LISTEN '
tcp        0      0 127.0.0.1:52815         0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:4559            0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:4369            0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:7634          0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:5269            0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:5280            0.0.0.0:*               LISTEN     
tcp        0      0 127.0.1.1:7777          0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:33601           0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:5222            0.0.0.0:*               LISTEN     
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN     
tcp6       0      0 :::139                  :::*                    LISTEN     
tcp6       0      0 ::1:631                 :::*                    LISTEN     
tcp6       0      0 :::445                  :::*                    LISTEN     

/etc/hosts.deny is empty:

adp@adp-desktop:~$ cat /etc/hosts.deny 
# /etc/hosts.deny: list of hosts that are _not_ allowed to access the system.
#                  See the manual pages hosts_access(5) and hosts_options(5).
#
# Example:    ALL: some.host.name, .some.domain
#             ALL EXCEPT in.fingerd: other.host.name, .other.domain
#
# If you're going to protect the portmapper use the name "portmap" for the
# daemon name. Remember that you can only use the keyword "ALL" and IP
# addresses (NOT host or domain names) for the portmapper, as well as for
# rpc.mountd (the NFS mount daemon). See portmap(8) and rpc.mountd(8)
# for further information.
#
# The PARANOID wildcard matches any host whose name does not match its
# address.
#
# You may wish to enable this to ensure any programs that don't
# validate looked up hostnames still leave understandable logs. In past
# versions of Debian this has been the default.
# ALL: PARANOID

netstat -l:

adp@adp-desktop:~$ netstat -l
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
tcp        0      0 localhost:52815         *:*                     LISTEN     
tcp        0      0 *:hylafax               *:*                     LISTEN     
tcp        0      0 *:www                   *:*                     LISTEN     
tcp        0      0 *:4369                  *:*                     LISTEN     
tcp        0      0 localhost:7634          *:*                     LISTEN     
tcp        0      0 *:ftp                   *:*                     LISTEN     
tcp        0      0 *:xmpp-server           *:*                     LISTEN     
tcp        0      0 localhost:ipp           *:*                     LISTEN     
tcp        0      0 *:smtp                  *:*                     LISTEN     
tcp        0      0 *:5280                  *:*                     LISTEN     
tcp        0      0 adp-desktop:7777        *:*                     LISTEN     
tcp        0      0 *:33601                 *:*                     LISTEN     
tcp        0      0 *:xmpp-client           *:*                     LISTEN     
tcp        0      0 localhost:mysql         *:*                     LISTEN     
tcp6       0      0 [::]:netbios-ssn        [::]:*                  LISTEN     
tcp6       0      0 localhost:ipp           [::]:*                  LISTEN     
tcp6       0      0 [::]:microsoft-ds       [::]:*                  LISTEN     
udp        0      0 *:bootpc                *:*                                
udp        0      0 *:mdns                  *:*                                
udp        0      0 *:47467                 *:*                                
udp        0      0 192.168.1.10:netbios-ns *:*                                
udp        0      0 192.168.91.1:netbios-ns *:*                                
udp        0      0 192.168.156.:netbios-ns *:*                                
udp        0      0 *:netbios-ns            *:*                                
udp        0      0 192.168.1.1:netbios-dgm *:*                                
udp        0      0 192.168.91.:netbios-dgm *:*                                
udp        0      0 192.168.156:netbios-dgm *:*                                
udp        0      0 *:netbios-dgm           *:*                                
raw        0      0 *:icmp                  *:*                     7          

netstat -rn:

adp@adp-desktop:~$ netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
192.168.91.0    0.0.0.0         255.255.255.0   U         0 0          0 vmnet1
192.168.156.0   0.0.0.0         255.255.255.0   U         0 0          0 vmnet8
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth0

commands on the laptop, 192.168.1.102:

ifconfig:

root@fakeuser-laptop:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1c:33:a2:31:15 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:21

eth1      Link encap:Ethernet  HWaddr 00:2d:d9:3e:1f:6c 
          inet addr:192.168.1.102  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe70::21d:d9ff:fe3e:1f6c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5681 errors:0 dropped:0 overruns:0 frame:10313
          TX packets:6717 errors:6 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4055251 (4.0 MB)  TX bytes:779308 (779.3 KB)
          Interrupt:18

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:206 errors:0 dropped:0 overruns:0 frame:0
          TX packets:206 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:15172 (15.1 KB)  TX bytes:15172 (15.1 KB)

netstat -rn:

root@fakeuser-laptop:~# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth1
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth1

telnet:

fakeuser@fakeuser-laptop:~$ telnet 192.168.1.101 25
Trying 192.168.1.101...
telnet: Unable to connect to remote host: Connection timed out
fakeuser@fakeuser-laptop:~$ telnet 192.168.1.101 22
Trying 192.168.1.101...
telnet: Unable to connect to remote host: Connection timed out
fakeuser@fakeuser-laptop:~$ telnet 192.168.1.101 80
Trying 192.168.1.101...
telnet: Unable to connect to remote host: Connection timed out
share|improve this question
2  
You can also type netstat -l to discover what ports are listening to what. Maybe your web server is listening only the loopback interface. –  Javier Rivera Dec 27 '10 at 8:12
2  
Agreed - all looks good, but since they can ping each other, I can't see how the routes are relevant. Worth a shot though! This is looking more and more like an Apache problem. How was the web server configured? –  Scaine Dec 27 '10 at 13:51
1  
Hey - just noticed that your laptop has over 10K frame errors! This is worth googling and researching. I'm not sure what would cause that, but since it's on the receive packets, it might explain the timeouts... –  Scaine Dec 27 '10 at 20:40
1  
Frame Errors: An incorrect CRC and a noninteger number of bytes are received. This is usually the result of collisions or a bad Ethernet device. –  Scaine Dec 27 '10 at 20:44
1  
There is a easy way to rule out apache problems. It looks like you have a smtp server on that machine too. Can you telnet to port 25 from the laptop? –  Javier Rivera Dec 28 '10 at 8:37

1 Answer 1

Additional information you provided in your question points to an issue with your laptop's ethernet connection. There are over ten thousand frame errors reported in your ifconfig output.

  • Frame Errors: An incorrect CRC and a noninteger number of bytes are received. This is usually the result of collisions or a bad Ethernet device.

This is sometimes caused by a switch port being set to 100/full duplex when your card is configured as auto/auto. To confirm perform this on your laptop :

sudo apt-get install ethtool
sudo ethtool eth1
share|improve this answer
    
thanks, i ran sudo ufw disable and then tried again. still timed out. other commands' results are provided in question. –  Alexar Dec 27 '10 at 12:33
2  
This looks like it's an Apache problem - all other connectivity looks good. I'm no Apache expert, hopefully someone else can help. –  Scaine Dec 27 '10 at 13:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.