Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been having a lot of problems regarding networking on my Ubuntu laptop. From Windows, everything works fine. When I wire directly into the modem, it works fine, but when I am on my wireless network (and I've tried wiring into the network as well), I've been having problems with web form, and sometimes site logins. Not all web forms have this problem, but on many, I submit the form, and nothing happens for a minute or two. Then, in Firefox, it says the connection was reset. In Chrome, it says "This web page is not available. The connection to was interrupted.

This was all I knew until I got another clue when I refreshed one of the error pages. It said "Can not upload file - Too large for php post_max_size directive". I only wrote a sentence! Any idea why it does that?

share|improve this question
I have exactly this problem, too. In windows, everything is fine. But in Ubuntu (12.xx, 13.xx, 14.xx), many form submissions fail with timeout in both Chrome and Firefox. This is not a network problem. – Paulo Coghi Apr 8 '14 at 20:33
Please specify the links on which you have errors. – Danatela Apr 11 '14 at 5:25

Your problem could be many things.

Try using ping from the command line with these options:


You should get the responses back normally. Then try this:

ping -s 1300 -M do

which will determine if you are getting packet loss. That will detect whether you've got a networking problem with the MTU settings. I had that once and it produced a variety of effects.

If your Ubuntu is set up to use an MTU (max transmission unit) packet size of 1500 but your ISP's gateway is only allowing 1000, then you'll get packet loss and problems like you describe.

It's made worse if you have a firewall on your router that is blocking the ICMP packets that should notify you of the error (happens a lot because some sysops think ICMP packets are evil).

You can also try resetting the router to its factory defaults.

share|improve this answer

I am not sure this will work or not . But I think you can check the website with

If the website is working then install add-on to your browser form

try to visit the website again. Actually it worked for me several times. Hope it works for you too.

share|improve this answer
Thanks, Rashed. But this is not the problem. I can access the site, but can't use any form, like login forms. Worst, in most of sites, everything works, but in a few ones, the forms don't submit. – Paulo Coghi Apr 11 '14 at 13:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.