Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been getting this annoying problem. I want to compile a .so under Ubuntu using the Anjuta IDE. It compiles fine and all, but when I load it, that's when the error comes up:

/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found

I've tried everything in GLIBCXX_3.4.15 not found. But nothing seemed to work.

share|improve this question
    
If you use a ppa with a newer version of gcc or other packages, it might be a problem in older versions of ubuntu (older than 11.10) because of multiarch. Which ubuntu version do you use? Can you try a live cd of ubuntu 12.04 and see if the problem persists there too? Also, can you post the output of: dpkg -l gcc* libst* | grep ^ii | awk {'print $2, $3'} –  medigeek Sep 17 '12 at 5:45
    
Thanks for the response. Here's the output: gcc 4:4.6.3-1ubuntu5 gcc-4.6 4.6.3-1ubuntu5 gcc-4.6-base 4.6.3-1ubuntu5 gcc-4.7-base 4.7.0-7ubuntu3 libstartup-notification0 0.12-1ubuntu1 libstdc++6 4.7.0-7ubuntu3 libstdc++6-4.6-dev 4.6.3-1ubuntu5 libstlport4.6ldbl 4.6.2-7 Also, I'm using version: ubuntu-12.04.1-desktop-i386. Running it in a virtual machine on Windows 7 64 bit. –  user1667191 Sep 18 '12 at 1:27
    
Also the output of: apt-cache policy libstdc++6 libstdc++6-4.6-dev -- I have ubuntu 12.04 and I don't see a 4.7 version of the libstdc++6 package. Do you use packages from launchpad PPA repositories? –  medigeek Sep 18 '12 at 9:52
    
To be honest, I'm not sure anymore. I've tried so many things people posted that supposedly would fix this, including installing new packages. ( Lost track of what I've installed, and I'm new with Ubuntu, so yeah ).. Here's the output of that command: ( pasting in pastebin ): link –  user1667191 Sep 19 '12 at 0:05
    
Well, I would try using a live cd/usb. If it works there, it most definitely is a problem in your installation. –  medigeek Sep 19 '12 at 6:26
add comment

1 Answer

have you tried adding the /usr/lib/x86_64-linux-gnu to the LD_LIBRARY_PATH environment variable?

I did and worked. Let me know if this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.