Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.04 onto my HP Pavilion, in an attempt to make the desktop able to dual-boot Windows 7 and Ubuntu. I managed to get down to the last step, and finished the installation process. After it prompted me to remove what I used to install Ubuntu, I did so, removing my SanDisk 8GB flash drive, and allowed the system to reboot.

Like usual, the desktop booted with the HP image, with the options at the bottom(Boot Menu, System Recovery, etc). However, when it should have started up with Ubuntu(like I'm certain it should have done), I received the following error:

Input signal out of range Change settings to 1600 x 900

From the time I installed the operating system, back in late August, till now, I've been trying to figure out how I would go about fixing this issue. My mom is also starting to get frustrated with my not having resolved the issue, as its the only desktop that has a printer installed.

Is there any possible way to resolve this?

To summarize the problem:
-Successful boot
-Screen brings up error
-Screen goes to standby
-Nothing else possible until desktop is rebooted, which will initiate the above three steps

A few notes:
-I did not back up my computer before I installed Ubuntu. I didn't have anything to write to, and basically just forgot to.
-I don't have a Recovery Disk.
-I don't have the Windows 7 disk that is supposed to come with the computer.
-It has been narrowed down by a friend on Skype that the problem lies with the display, and that the vga= boot command does have something to do with fixing the problem

Thank you in advance for resolving this problem. I greatly appreciate it.

share|improve this question
    
HI Clayton,Can you boot into ubuntu? If not, when seeing the out of range message, try pressing enter and see if ubuntu boots.If ubuntu boots, try this fix askubuntu.com/a/153046/71679. If not please report back –  damien Sep 16 '12 at 23:22
    
Welcome to Ask Ubuntu! Can you try booting into recovery mode by pressing Shift during early boot, and then select the Recovery mode option? Then use failsafe graphics mode to troubleshoot. –  hexafraction Sep 16 '12 at 23:25
    
@damien: I pressed Enter, and it brought up the login screen for Ubuntu(in what looks like a boot/terminal page, but I'm guessing that's what it should look like). 'Course, it looks like the keyboard is unresponsive on the Password: section, but I could try and see if I can fix that. Thanks. ^^ –  Clayton Sep 17 '12 at 1:57
    
@ObsessiveFOSS: Shift didn't seem to work when I tried pressing it. :\ Thanks, though. –  Clayton Sep 17 '12 at 1:58
    
@ Clayton are you seeing a purple background,your user name,a password box,guest session and at the bottom of the page ubuntu 12.04 ? If so Is your mouse also unresponsive? Reboot and try again and see if the problem persisted. –  damien Sep 17 '12 at 2:39

2 Answers 2

It appears from your comments, you have several problems

First lets try and resolve your original signal out of range issue.

If you are able to log in from the terminal with username and password IE the screen you are seeing.

You can try fixing the frequency out of range issue,that is currently hiding grub, by running:

sudo nano /etc/default/grub

Press enter

If prompted for password,add it, and press enter again

Using the arrow keys for up and down

find the line #GRUB_GFXMODE=640x480

and change to GRUB_GFXMODE=640x480

when finished making the changes hold down Ctrl button and press x

You should be asked if you wish to save,if so choose y

Now run:

sudo update-grub press enter

reboot your machine and hopefully you will at least see ubuntu and windows in your grub menu

If you still dont see grub, but the frequency out range no longer exists,then do as ObsessiveFOSS suggested and hold down shift during the next boot.This should bring grub out of hiding

Option 2 If not able to log in,its probably best to boot the live cd again and use the boot repair tool.

You can find detailed instructions here http://askubuntu.com/a/139142/71679

Whilst using boot repair its also possible to fix the out of range issue, as suggested above, with a simple tick of a box. To do this

Click Advanced options

Go to the GRUB options tab

Tick the out-of-range option

Apply

Reboot

Again if the frequency error message is gone but grub is not showing try holding the shift key

share|improve this answer

Same problem happened to me in my HP Pavillion, if anyone is interested. The thing was that Ubuntu did not install the proprietary drivers for the graphics card. To fix all at once I did the following:

Press the "down arrow" once during the Out of range message and hit enter to go to recovery mode.

Select the first option, resume normal boot to get to safe mode. (Running failsafe graphic mode did not work for me)

After booting you need to do two things: 1)Open a terminal window to fix the grub issue as stated in the previous post by damien. 2) Fix the graphic card driver:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

This solved every problem for me. I can see my grub screen and the graphics card is working fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.