Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just bought an external monitor for my laptop (Asus VH242H) but cannot set its resolution to anything higher than 1600x900. I tried both from System/Administration/Monitors and the ATI Catalyst Control Center. There was a CD that came with the monitor but it only contains a Windows installer.

According to the monitor's specifications:

23.6” 16:9 widescreen with 1920×1080 resolution enables borderless Full HD 1080p full-screen video display.

My graphic card is an ATI Mobility Radeon HD 4670 and the monitor is currently connected to my laptop with a VGA cable.

How can I set my external monitor to its maximum resolution?

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

Ah, AMD graphics. Finicky at best.

1) If you can, try a DVI/HDMI cable. My laptop doesn't like external monitors larger than the internal screen when using a VGA cable.

2) Add the X-Swat PPA to your system and update your graphics drivers.

3) Check in CCC, under Display Manager, that Multi-Display is set to "Multi-display desktop with display(s) ...". Under Display Properties check Resolution is set correctly, then Apply. If this changes the overall Desktop Area you should be asked to save the changes and restart the machine; if this hasn't happened go to 4)

4) Purge fglrx from your system (e.g. sudo apt-get purge fglrx, then sudo rm /etc/X11/xorg.conf) Restart the laptop with the monitor connected; this will use the Open Source drivers, so you will lose Compiz and desktop effects. Now reinstall and re-enable fglrx, all with the external monitor connected to make sure it is picked up when the installer generates xorg.conf.

Multi Display

Desktop Area

share|improve this answer
    
Thanks. Reinstalling fglrx worked but now I lost access to the CCC :( At least my external monitor's resolution is OK now. –  Olivier Lalonde Dec 27 '10 at 2:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.