Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Minimum goal: Ability to switch between the graphic cards without drivers re-installation. Restarting computer in the process is fine.

There are lots of 'how to get switchable graphics to work' guides but I found none on how to configure a system for switchable graphics operation on Ubuntu from the ground up, nor explaining the current driver situation for particular computer models (integrated+discrete combinations).

Examples: https://help.ubuntu.com/community/HybridGraphics http://www.thinkwiki.org/wiki/Switchable_Graphics

My system being mature and on Intel integrated card also makes things complicated.

System information:
Ubuntu 12.04 amd64, installed clean with system configured to use only the integrated Intel card Lenovo Thinkpad T500
Intel GMA 4500MHD / ATI Mobility Radeon HD 3650

Current situation:
Mature and up-to-date system with no configuration changes to what's given above.
I've made a backup image of the system (Clonezilla) so regardless of what's written below let's assume it's our starting point. If something in What I have already tried is not clear you may as well diregard it.

What I have already tried:
Configuring BIOS to switchable graphics and:

  1. Installing Additional Hardware drivers - returned an error.
  2. Installing proprietary amd-driver-installer-12.6-legacy-x86.x86_64.run automatically - system starts to 'low-graphics mode'.
  3. Tried fixing as per https://help.ubuntu.com/community/BinaryDriverHowto/ATI#Manually_installing_Catalyst_12.6.2C_special_case_for_Intel.2BAC8-ATI_hybrid_graphics
  4. Got lost, gave up.

BIOS settings:
Please note that while configuring BIOS for integrated graphics only is pretty straightforward, configuring for switchable graphics is not. Despite that if you know the driver installation part well, I'm willing to test all the BIOS settings combinations on my own.

share|improve this question
    
Have you tried out this method? ubuntuforums.org/showthread.php?p=11712748 (although this has only been confirmed to work on AMD HD6xxx series and up) –  Glutanimate Sep 19 '12 at 21:27
1  
@Glutanimate No, I haven't. Reason: ubuntuforums.org/showthread.php?p=12242803#post12242803 –  Bucic Sep 19 '12 at 21:41
    
I'm heavily interested in this question. What will be the use of having it done this way. –  kmassada Oct 4 '12 at 8:41
    
@kmassada It's not any particular way. It's about switching graphics, that's it. I just specified that even the most primitive method is allowed, even involving computer restart. The only thing I don't want to do is installing drivers from scratch each time I'd like to use another graphics chip, as I don't think it could be defined as 'switching'. That's all. –  Bucic Oct 5 '12 at 21:01
add comment

2 Answers 2

I found a solution for while googling. You have to put a script in rc.local specifying which VGA you want to use.

This link explains everything.

I will post important notes here:

  1. First install needed driver and script from git

    sudo apt-get install git && cd ~/  
    git clone https://github.com/mkottman/acpi_call.git  
    cd acpi_call && make  
    sudo insmod acpi_call.ko  
    chmod a+x test_off.sh
    
  2. de-activate ATI VGA

    sh test_off.sh
    
  3. Now you can check if your ATI VGA is already disabled by lspci -vnnn | grep VGA.
    It will show the following output:

    00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller]) 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc NI Seymour [AMD Radeon HD 3650M] [1002:6760] (rev ff) (prog-if ff)

  4. If it works, to make this run at boot, edit /etc/rc.local:

    sudo insmod /acpi_call/acpi_call.ko
    sudo sh /acpi_call/test_off.sh
    
  5. Also, remove radeon blacklisting by editing /etc/modprobe.d/blacklist.conf:

    #blacklist radeon
    

    You should have xorg.conf like this to make VGA detectable :

     Section "ServerLayout"
     Identifier "aticonfig Layout"
     Screen 0 "aticonfig-Screen[0]-0" 0 0
     EndSection
    
     Section "Module"
     Load "glx"
     EndSection
    
     Section "Monitor"
     Identifier "aticonfig-Monitor[0]-0"
     Option "VendorName" "ATI Proprietary Driver"
     Option "ModelName" "Generic Autodetecting Monitor"
     Option "DPMS" "true"
     EndSection
    
     Section "Device"
     Identifier "aticonfig-Device[0]-0"
     # Driver "fglrx"
     BusID "PCI:1:0:0"
     EndSection
    
     # Section "Screen"
     # Identifier "Default Screen"
     # DefaultDepth 24
     # EndSection
    
     Section "Screen"
     Identifier "aticonfig-Screen[0]-0"
     Device "aticonfig-Device[0]-0"
     Monitor "aticonfig-Monitor[0]-0"
     DefaultDepth 24
     SubSection "Display"
     Viewport 0 0
     Depth 24
     EndSubSection
     EndSection
    

Note: To activate ATI/AMD radeon VGA again: Just comment what we've added to rc.local

Solution 2

I found this solution from askubuntu.com, I might be easier to put into practice:

This question assumes using vga_switcheroo.

Add this to /etc/fstab:

none  /sys/kernel/debug debugfs defaults 0 0
share|improve this answer
    
Thanks for your input. I won't be able to test it before the bounty ends (tomorrow). Have >you< actually tested it? Are you sure the procedure addresses this particular question? Isn't it the case that the authot from cisight.com always uses his Intel graphics, regardless of having his ATI/AMD switched on or off? –  Bucic Oct 5 '12 at 21:07
    
first, Sorry I don't have right now a dual graphics card to test it. Second, I Noted how to re-enable ATI again, You can choose which card you want. –  user91632 Oct 6 '12 at 6:11
    
Since the bounty is ending soon and I can't confirm your answer validity, I'll mark your quwstion and you'll get the bounty. However if the answer turns out invalid, I'll ask moderator to unmark it, if possible. –  Bucic Oct 7 '12 at 7:13
    
Error in Solution1: After ~/acpi_call$ chmod a+x test_off.sh I get the following error: chmod: cannot access `test_off.sh': No such file or directory . No other errors up to this point. –  Bucic Dec 27 '12 at 20:27
add comment
up vote 0 down vote accepted

This is currently not possible with AMD/ATI proprietary drivers. Please refer to Any way to make switching between discrete and integrated graphics from the BIOS work with proprietary drivers?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.