Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to get the nvidia drivers to output 720p component (as they did in my 10.10 system), I've hosed my Mythbuntu 12.04 config in some way. The current status is this:

  • When I boot the PC I get to this login window:Log-In Window
  • If I enter my password and select Fred Hamilton, I get the following on-screen text, then it returns to the above log-in screen: Text Log
  • If I select Guest Account, it launches fine (into Ubuntu, Ubuntu 2D, Xfce, or Mythbuntu)

Why can't Fred Hamilton launch the GUI?

I also noticed that when I launch as FH, an Xorg.0.log file is generated (it's too long for askubuntu's 30k limit so it's not here, but I didn't see anything obviously wrong in it). When I launch as guest, no log file is generated at all...

share|improve this question
Do you get an .xsession-errors file in your $HOME directory? Also, can you drop to a terminal (Cntl-Alt-F1) and log in with FH? If you can, try running DISPLAY=:0 unity --reset to see if you can reset Unity and run it. – Ian B. Sep 16 '12 at 19:33
@IanB. You can't run Unity that way, because when the login screen is up, the user is not logged in, and the display does not belong to the user running it. – Eliah Kagan Sep 16 '12 at 19:35
@Eliah just realized that... sorry – Ian B. Sep 16 '12 at 19:38
How about backing up (renaming) your home directory (or the $HOME/.config) to something else and creating a new home directory? – Ian B. Sep 16 '12 at 19:39
@EliahKagan I was thinking he could just rename certain config directories or add back a directory at a time to isolate the offending configuration files. I've done this approach before and it worked for me. Please go ahead though and write up your approach – Ian B. Sep 16 '12 at 19:49

This is probably a bug, but the workarounds for this sort of problem are generic, and applying the workaround will help in reporting the bug initially. (So while most bug questions are closed as off-topic, I'm answering this one with a workaround. Also, I suppose it's possible that this could happen as the result of some misconfiguration, rather than bug.)

How to Get a Successful GUI Login as "Fred Hamilton"

Press Ctrl+Alt+F1 to open a text-based virtual console. Log in with Fred Hamilton's username and password. But take note:

  1. The username will not actually be Fred Hamilton. It will be the short name. (You may recall having put in both a short username and a full name, when you installed Ubuntu.) If you don't remember what this is, it's probably fred. But some users make their initials (for example, mine is ek), or something entirely different.

    If you don't know what this is, you can log in as Guest, and try to see what subfolders exist inside the /home folder. These subfolders are the folders for each human, non-guest user (so there's probably just one--the one for Fred Hamilton).

  2. Unlike when logging in graphically, nothing will change on the screen as you type in your password. You won't see any placeholder characters like *. This is by design. Just type in your password and press Enter.

Now you can run commands. Make sure you're connected to the Internet (you can connect in a simultaneous guest session if necessary, switching to the GUI with Alt+F7 and back to the first virtual console with Ctrl+Alt+F1). Run this command, by typing it in and pressing Enter.

sudo apt-get update && sudo apt-get install gdm

This will install gdm, an alternative to lightdm. LightDM and GDM are two different display managers. A display manager is the part of the GUI that provides the graphical login screen. Since the LightDM login screen is not working, installing GDM and configuring it to be used instead of LightDM should eliminate the problem.

Please note:

  1. You'll be prompted for your password. As you enter it, you won't see anything change (as before).

  2. As the final installation step, the gdm package will be configured and you'll get to choose whether you want to use LightDM or GDM as your display manager. Choose GDM. You can use the arrow keys and the Enter key to make this selection, when the menu comes up asking you which you want to use.

    • Strictly speaking, you don't have to choose gdm, as you'll be manually switching to it anyway. But LightDM (which is currently broken and causing this problem) will continue giving you the bad login screen, unless you select GDM. You can always reconfigure this later, with sudo dpkg-reconfigure gdm or sudo dpkg-reconfigure lightdm.

Then stop lightdm and start gdm:

sudo stop lightdm
sudo start gdm

Now switch back to the GUI (Alt+F7) and log in as Fred Hamilton.

How to Report This As a Bug

First, read the official bug reporting instructions for Ubuntu carefully. (The answers here are also a helpful resource.)

Then report this bug against the lightdm package in Ubuntu, by pressing Alt+F2 and running the command ubuntu-bug lightdm.

Here are a couple of specific considerations, when writing your bug report:

  • Make sure to describe the problem in detail. In particular, developers should not have to come here, to fully understand and appreciate the bug you're reporting.

  • Make sure that an Xorg.0.log file created from a LightDM session (not from the current GDM session) is attached. Xorg.0.log and Xorg.0.log.old will usually be attached automatically, and Xorg.0.log.old will likely be the correct file. If you're at all unsure, you can also attach the Xorg.0.log file you currently have, if you made a copy of it before logging in again. (Just make sure to give it a description that makes clear what the difference is between it and the Xorg.0.log file automatically attached.)

In case somehow this is not a bug, you might also want to paste the contents of the appropriate Xorg.0.log file at and edit your question here (or post a comment) to provide a link to it.

This question might be considered a duplicate of this older question. (Thanks to aking1012 for finding that.) If so, and this is closed as a duplicate of that question, this answer can probably be merged, and then I can edit accordingly.

share|improve this answer
Thanks for the fast, detailed response. Yes, I know my actual username is fred, I was just trying to be consistent with the screenshot. I will keep the gdm installation in mind, but since I seem to be able to make lightdm work as guest, and before I started messing with the nvidia driver I was able to make lightdm work with fred, I'd rather find the root cause of what went wrong with launching lightdm. I did try "sudo dpkg-reconfigure lightdm" from the 'possible duplicate' question you mentioned, but no change... Thanks again. – Fred Hamilton Sep 16 '12 at 21:11
@FredHamilton I think the best way for you to get the underlying problem solved is to report this as a bug. However, on consideration, it seems plausible that the bug might be in your Nvidia drivers rather than LightDM. I'd still recommend reporting it in LightDM though, as that's what's failing. (I think a good bit of the information that Apport will attach automatically, will be the same for both.) – Eliah Kagan Sep 16 '12 at 21:56

Mate, hit

Ctrl + Alt + F1

run this in terminal:

sudo dpkg-reconfigure gdm

Choose lightdm or gdm, see if things come back to normal.

Exactly that happened to me once when I tried to customize lightdm with lightdm-webkit, but the steps I told you worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.