Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed Ubuntu 12 and started up Firefox so I could configure it. But there doesn't seem to be any way to access preferences. No menu bar appears at the top. right-clicking (in multiple places) doesn't seem to work either, no option to open the preferences window is available. Nothing seems to work. All I can do is change my home page by dragging the URL onto the Home button. Help!

share|improve this question
    
Is it 12.10 or 12.04? –  smartboyhw Sep 20 '12 at 14:48
add comment

6 Answers 6

In Ubuntu Unity, the menu is in the top dark bar (the panel). You should put the cursor there, then click Edit, and then Preferences.

If the menu stills don't work, try installing the last updates by opening the Update Manager and updating all the packages listed there. After updating, restart the computer and start firefox again. The problem should be fixed if you follow this steps, but if it still doesn't work, you can submitting a bug on Launchpad.

I hope it gets fixed!

share|improve this answer
1  
@okinawa_dato Alternatively you can also press the Alt button on your keyboard to activate the HUD and search for any menu entries within Firefox. Same thing goes for any other application Ubuntu ships with. –  Glutanimate Sep 16 '12 at 17:34
add comment

By default the menu is hidden...

When there is no cursor on the title-bar

Menu appears when you hover the cursor over the title-baar... Cursor on the title-bar...

share|improve this answer
    
And how can I make it appear permanently. –  Bevor Jul 2 '13 at 5:54
    
No.. I am not sure but I think there is no option in de default theme.... you need some software that allows to configure the theme/appearance like Unity. I am also not sure if Unity allows to make it permanent or not... But please post it here if you are able to make it permanent in the future... :) –  Sam Jul 9 '13 at 11:29
    
I found the solution shortly after this post. I had to go to about:config and set ui.use_unity_menubar to false. –  Bevor Jul 9 '13 at 11:38
    
My Firefox has no such option "ui.use_unity_menubar"... any idea? –  Sam Jul 9 '13 at 12:16
    
Try to add this attribute in about:config by right click->new boolean -> ui.use_unity_menubar -> value -> false. –  Bevor Jul 9 '13 at 13:49
add comment

I just upgraded from 11.## to 12.10 and noticed the same missing menu links. After a few minutes of reading I decided to check on keyboard short cuts, lo and behold F10 displays menu options when hover mouse over web page description/name top left.

Keyboard shortcuts - Perform common Firefox tasks quickly

http://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#w_windows-tabs

Toggle Full Screen F11 Toggle Menu Bar (when hidden) Alt (KDE) F10 (GNOME)

share|improve this answer
add comment

This is the only solution that works.

Navigate to about:config, search for 'unity', and toggle from true to false.

That did it for me just now.

(the full preference name is ui.use_unity_menubar)

See: Global menu bar integration add-on missing in Firefox 22 for Ubuntu 12.04

share|improve this answer
add comment

For me, Firefox menu strangely does NOT appear on the panel (unlike almost all other applications). The first time I ran Firefox (that is today!) I didn't see any menus either. But this is a simple problem to fix. Just drag the window down a little bit and the menu will show up. The firefox menu is not on the panel, but instead part of the firefox window itself. It is probably just hidden below your top panel and that's why you don't see it.

share|improve this answer
    
Then you should maximize the window, maybe then it should work. –  Addison Montgomery Sep 16 '12 at 18:01
    
I just restarted my computer, after updating firefox, and its menubar is now on the top panel as expected. –  stacksia Sep 16 '12 at 18:25
    
Yay, updating usually solves a lot of problems :) –  Addison Montgomery Sep 16 '12 at 19:00
    
You should include your comment as part of your answer. –  RolandiXor Sep 27 '12 at 2:09
add comment

Open Firefox - in the top-left corner there is a 'Firefox'-button (red) - click on it - go to options and select 'Show menu'.

After that, I think you should now see what you want to see.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.