Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Original posting started Sep 21:

I am trying to use the Wubi installation process to create a Ubuntu 12.04 / Windows 7 dual boot setup on my Windows 7 machine (Dell Inspiron 17R). The installation initially works fine, and I am able to load Ubuntu several times after selecting it from the boot menu. However, when I boot into Windows 7 it seems to corrupt the Ubuntu boot process, because after running Windows 7, Ubuntu won't boot on the machine. It is still listed as an option in the boot menu, but when it is selected, the machine does one of the following:

  • hangs at the load-screen and says that Ubuntu is preparing to run for the first time (although it isn't the first time the OS has been loaded)

  • hangs with a black screen and does nothing

I have uninstalled Ubuntu and then reinstalled it (using Wubi) three times. Each time Ubuntu initially boots okay (including rebooting the laptop into Ubuntu several times.) However, whenever I switch over and boot into Windows 7 it breaks the Ubuntu installation. Windows 7 continues to boot and work fine without issues.

I have successfully installed Ubuntu using Wubi onto a different Windows 7 machine before without problems...it seems that there is something different about this laptop configuration. I am not sure how to debug the issue. I see no error messages during the Ubuntu boot process when it hangs and am not sure how to debug this.

Updated Info: I made some progress on this issue, but am now stuck with a broken bootloader. I was able to get the Ubuntu installer to install version 12.04 on the system, but at the moment the boot process is not working and right at boot it hangs and says: “BOOTMGR is missing” The most recent boot debug info I have is: http://paste.ubuntu.com/1218834. Here is what I did:

1) Turned off Intel rapid start technology in the Windows control panel on the taskbar, but leave RAID 0 setup with the Intel tech in the BIOS. After reading into this a bit, I believe the setup on this system is fakeRAID/ software RAID/sataRAID where BIOS makes the 2 SATA drives look like RAID to the OS. According to Intel, linux should support this (http://download.intel.com/design/intarch/PAPERS/326024.pdf) and the preferred mechanism is mdadm in linux rather than the dmraid approach which is now only in bug-support mode by the Intel people. I want to keep this feature active to maintain a good performance of Windows 7 while also setting up a dual-boot environment.

2) Inside windows, using their disk management tool, I shrunk the windows partition by 30 GB to free up space for Ubuntu.

3) I (temporarily) disabled the Intel Rapid Start feature using the taskbar controls inside Windows 7. I did not disable the feature in the BIOS and left the BIOS configured with sataRAID active.

4) It was possible to boot the computer into Ubuntu 12.04 using a LiveCD installed on a USB stick.

5) Next, confirm that the partitions looked the same from within Ubuntu as they did when I looked at them inside Windows 7 from the disk manager tool.

6) Install Gparted package and use it to configure the partitions in prep for Linux install. Created 1 extended partition subdivided into three logical partitions (swap, root, and home)

7) Ran the Ubuntu installer, used the manual partition control rather than the automatic option for installing Windows 7 and Ubuntu side-by-side.

8) When the machine rebooted, it went straight into Windows 7 without any sort of grub2 menu.

9) Boot into Ubuntu from liveCD USB stick, install boot-repair and use it to try and fix the boot loader process.

10) The boot process now starts up Ubuntu 12.04 okay, but there was no option to load Windows 7.

11) Install boot repair and try to force it to load Windows 7 first (although, admittedly, not to clear on how best to try this. I tried to get it to refresh the MBRs.)

12) On reboot the computer says “BOOTMGR is missing” and hangs…no grub2 menu

Now I’m not sure how to proceed. I think the partitions are setup okay and I actually have Ubuntu 12.04 installed okay and Windows 7 installed okay, too, but how do I get a grub2 menu setup that will allow me to select between the two OSes?

--Final update on Oct 25:

So, after a lot of pain investigating this, I gave up and installed Linux onto an external USB hard drive, thus keeping the RAID setup across the internal HDD and SSD independent of the Linux installation. From inside Windows it was possible to configure the boot menu to give an option to boot linux off the external USB drive.

This RAID hardware configuration doesn't seem to be supported by the wubi installer, standard Ubuntu ISO installer/Live CD, or the alternative Ubuntu ISO installer.

A few notes on what partly worked and didn't work:

After booting into Ubuntu using the Live CD, it is possible to use 'dmraid -ay' to activate the RAID0 partitions, and it is possible to use gparted to partition them. If the installer is then subsequently run, it is able to see the partitions and proceed with installation, however, it is unable to install the boot loader at the end, and I was not able to resolve that. Also, fundamentally, it seemed like the dual-boot setup was unstable.

Apparently mdadm is actually preferable to dmraid for managing RAID arrays. However, when I tried to uninstall dmraid and install mdadm, mdadm was not able to see these RAID arrays, whereas dmraid had been successful. When I tried to get mdadm to recognize the RAID setup, it says that it doesn't support RAID0 on 1 device. Perhaps there is something unusual about how the Intel fakeRAID is setup in this setup.

Anyway, after wrecking the boot loader (tried using boot repair program in Ubuntu) and reinstalling Windows multiple times, this should work well enough. (The Windows setup is my primary OS, and Linux is secondary so I don't want to take the performance penalty of disabling the fakeRAID setup.)The windows installer needs me to manually provide the HD controller drivers for it to work right, too, so I think this is a fairly new type of configuration. Maybe a future version of the Ubuntu installer will be able to work with this kind of system. For now running off an external drive will work okay.

Some potentially useful links:

https://wiki.archlinux.org/index.php/Installing_with_Fake_RAID#Load_dmraid http://blog.neolocus.com/2012/04/ubuntu-12-04-lts-and-soft-raid-with-mdadm/

share|improve this question
    
Found a similar post on this issue where someone has the same laptop: askubuntu.com/questions/178635/… The HDD is setup with RAID controller...apparently Ubuntu installer doesn't support some of that functionality. Am investigating that now. –  Andrew Sep 19 '12 at 12:54

1 Answer 1

You must completely shutdown Windows before booting the Wubi Ubuntu. (Windows hibernation causes such problems).

share|improve this answer
    
Tried this, but doesn't seem to help, unfortunately –  Andrew Sep 19 '12 at 12:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.