Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My graphics performance with ati radeon HD3200 used to be terribly slow with unity (even the 2D performance). Installing the proprietary fglrx driver via the OS interface caused errors and problems.

So I opted for a manual installation. I downloaded the correct driver for 64 bit from AMD: amd-driver-installer-12.6-legacy-x86.x86_64.zip . This is the latest version to support the HD3200.

I enabled the restricted repositories and created the installation package. The manual installation worked without error messages, testing with fglrxinfo and fgl_glxgears works, everything is fast now.

My problem, however, is that after the first reboot, the whole screen is shifted about an inch to the left, so that I cannot see what is at the left margin of the screen. I could probably correct this via my monitor settings, but then I would have to change it back everytime I booted to Windows.

For the xorg.conf configuration I just used the recommendation I found on a Ubuntu helpsite:

sudo amdconfig --initial -f

I then changed my graphics card name in the Device Section.

Still the same screen problem.

The "monitor" section in the original xorg.conf file reads like this:

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection

Somewhere I found an info where someone recommended these settings for the same monitor I have: HP LP2065 with 1600 x 1200. The settings were:

Section "Screen"
        Identifier "Default Screen"
        Monitor "Configured Monitor"
        Device "Configured Video Device"
        SubSection "Display"
                Virtual 2560 1200
                Modes "1600x1200" "1280x1024" "1024x768" "640x480"
        EndSubSection

Unfortunately, I am still a Linux newbie and destroyed the x-server and had to reinstall everything because I had no backup of the xorg.conf file...

So maybe someone has an idea what the problem might be. I really would like to use the proprietary driver without having to adjust the monitor itself. Maybe I just need the correct xorg.conf settings...?

Any ideas?

share|improve this question
    
I have a similar problem with my dual monitor setup. Using FGLRX as well, screen shifted to the left by maybe 2-3 pixels. On the right side of the screen I have a 2-3 pxl wide column of unused space whose pattern corresponds with my wallpaper. Same thing for you? –  Glutanimate Sep 16 '12 at 16:03
    
Well, the shift of the screen is a bit less than an inch wide, so at least ten times as great as your shift (2-3 pixels). To the right there is an empty, black space. It really looks like before you adjust a new monitor in the horizontal axis, sometimes a new monitor is completely decentered. –  frank Sep 16 '12 at 20:58

1 Answer 1

I have a similar issue with my Radeon HD 6670 and using any of the regular,post-upgrade or from-amd.com drivers; well, actually, only the regular provided ones seem to work well enough (and I needed to wipe all old attempts properly before I reinstalled these ones for it to work, so I was just on vesa display module not even the open-source default "radeon" one).

I figured out the reason was that it uses a low refresh rate, 60Hz, and the monitor image is at least an inch, maybe two, inside the edges of my 19" monitor. When I start up amdcccle software (the Catalyst Control Center) I can fix it once logged in on Ubuntu 12.04 ("precise") when I click Apply button to set it to 85Hz (VGA CRT monitor, old style), and it shifts back out to fill the whole display.

But as soon as I reboot it the settings are forgotten and it jumps back to 60Hz. (edit: I just found it might be cos its on VGA, so no EDID: see link) I might try my own Q if Im still stuck in a day or two. If your problem is similar (check refresh rates via the monitor's on-screen-display menu in Windows then check them in Linux), then at least that determines a possible cause. You may have luck trying to set it in xorg.conf (mine doesnt help): in the Section "Monitor" bit if you have one, I use this line:

Option   "TargetRefresh" "85"

Where 85 is the rate that I know works (and would be your Windows rate if it doesnt match the broken Linux refresh rate).

Or with amdcccle program instead? My xorg.conf tries to tell it 85Hz but doesn't seem to be using that - though without an xorg.conf it doesn't work at all (I also have an in-board much older AMD gfx chip but I've disabled in bios, was Very broken with fglrx but ok with radeon driver when I didnt disable it).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.