Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to 12.04 on an old ACER Travelmate 5320 using Broadcom 4311. I wasn't able to connect to the internet through the wireless for a few days. It didn't even display wireless networks. I was finally able to make it work by following the instructions found here: http://linuxwireless.org/en/users/Drivers/b43#supported

However, each time I log on to the computer I have to go to the terminal and type sudo modprobe b43 to make the wireless work. Is there somehow I can avoid this?

I have used Ubuntu for many years but always relied on other people to help me with the technical stuff. The terminal is alien to me so I literally follow online forum instructions without knowing what I'm doing. Also, I tried many many things before I managed to make it work. So I'm worried I may have installed something that now conflicts with whatever the sudo modprobe b43 does.

Thank you

share|improve this question
add comment

1 Answer 1

Add b43 in a line to the /etc/modules file. It will load the module at boot time.

Alternatively, You can add b43 in /etc/initramfs-tools/modules and then use sudo update-initramfs -u to load the module automatically.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.