Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A few weeks ago I bought an Asus n76vm notebook looking forward to it's 'superior sound'. This sound system compromises an external subwoofer which amplifies bass and is connected to a special output jack. Ubuntu 12.04, however, does not detect this subwoofer. How could this be solved?

Any help would be gratefully appreciated

http://www.asus.com/Notebooks/Multimedia_Entertainment/N76VM/#specifications

share|improve this question
    
Try this : http://doc.ubuntu-fr.org/asus_n76vm#son It's in french but it's working for me. –  user92035 Sep 22 '12 at 11:28
    
This may be an anwser: askubuntu.com/questions/166261/…. –  Willem Sep 29 '12 at 11:45
    
worked for me! wiki.archlinux.org/index.php/ASUS_N55SF thanks for all the help given me! –  user287998 Jun 3 at 11:18

2 Answers 2

to get the subwoofer I added on the file /etc/modprobe.d/alsa-base.conf this line:

options snd-hda-intel model=asus-mode4

then rebooted and selected 2.1 output in audio pref. It should work right away :) got this information from Keyboard backlight not working on an Asus N56V

hope it helped!

share|improve this answer
    
I did what you said and rebooted. But there is 4.0 option instead of 2.1 when I select 4.0 subwoofer works as "rear right" and rear left is empty. How can I add 2.1 to sound preferences? –  Can May 13 '13 at 11:27

Which sound card are you using?

lspci | grep Audio

00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)

If so, I think you have a common problem with many new laptops: you are lacking the 2.1 surround mode enabled in your audio driver. Here a solution that worked for me: intel audio fix

here are three things to do:

  1. echo 'options snd-hda-intel model=asus-mode4' | sudo tee -a /etc/modprobe.d/alsa-base.conf
  2. sudo gedit /usr/share/pulseaudio/alsa-mixer/profile-sets/extra-hdmi.conf

    [Mapping analog-surround-21]
    device-strings = surround40:%f 
    channel-map = front-left,front-right,lfe,lfe 
    paths-output =
    analog-output analog-output-speaker
    priority = 7
    direction = out
    

    Note: On Asus N76VB running on the newer kernel 3.8.0-30, change the last line to be this instead:

    direction = output
    
  3. sudo gedit /etc/pulse/daemon.conf

    enable-lfe-remixing = yes
    
  4. Reboot.

You should now be able to see your "analog surround 2.1" among your possible Hardware settings in the sound menu.

"Analog Surround 4.0" is also working but changes the loudness from Front to Rear.

Additionally you can install the GNOME alsa mixer to boot your basses.

share|improve this answer
    
can this fix proposal be made more generic? so that more people con fix their subwoofer behaviours? –  Andrea Borga Nov 12 '12 at 21:00
    
This works for me, but now ALL of my sound is output through the mini-subwoofer and none comes through my standard speakers at all. –  David Perry Oct 4 '13 at 19:54
    
Working, but if i activate them, my mic stops working. –  Giuseppe May 5 at 20:51
    
analog-output analog-output-speaker should not be on spearate line. This way only "Dummy output" is available. If there is paths-output = analog-output analog-output-speaker, the outputs are visible. –  Michal Kováč Nov 7 at 12:24

protected by Community Jun 22 at 10:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.