Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

OBJECTIVE: Have a web browser on my Ubuntu install that can play youtube and hulu videos. Also would like to understand problem so that I can fix it again if I change software. Workarounds welcome, technical understanding and solution preferable.

SYMPTOMS: Flash does not run - cannot make the right-click menu appear, an empty box is where video should be, changes to black box when hovering over other links. The "The Adobe Flash plugin has crashed" message does not appear with its sad lego face.

cannot activate proprietary graphics driver - causes system to reboot to a prompt.

SOLUTIONS TRIED: Replaced OS (tried slackware 13.37, fedora 17, linuxmint 13 maya, gentoo, lubuntu, and even winXP. lubuntu confirmed to work, don't remember how much tweaking, if any, this required. Slack, fedora, mint, and gentoo all failed to run flash just like ubuntu)

many reinstalls of flash player via different methods, including cleaning up old installs first, also tried gnash and lightspark.

replaced graphics card (replaced HIS IceQ Radeon HD 4670 AGP with older GeForce 5700 LE no change in problem)

flash does successfully work on winXP installation with Catalyst AGP hotfix driver applied, however I consider windows wholly unacceptable for web browsing due to lack of security. Lubuntu install also works, however I do not want to be tied down to just using Lubuntu on this computer.

SYSINFO: Have latest versions of Ubuntu, Firefox, and Flash on fresh Ubuntu install. Using Gigabyte 7s748 motherboard with Athlon XP 2800+ and 3 GB of RAM with Radeon HD 4670 AGP card, also a Dell soundblaster live series sound card (due to malfunction of onboard sound on motherboard) Wired internet connection, Maxtor 6Y120L3 HDD, Sony DVD RW AW-Q170A, Dell M993s monitor.

NOTES: I do not know if the graphics driver issue and the flash troubles are linked. Substitution of older graphics card having same flash troubles seems to suggest they aren't. My troubleshooting method is rather reductionist, consisting mainly of "replace things until you find out what was causing the error by process of elimination" only it seems that this must be a conflict which arises when software decides how to configure itself on my hardware. That is, I know the hardware can run Flash, and I know that on other systems the same software can too, but somehow the combination fails. Consequently I feel out of my depth. I will keep trying things off and on, but I have spent probably about 30 man-hours in the last 4 months working on this problem with no joy other than the lubuntu workaround. Any help will be appreciated, I will be checking back and posting updates. Any pertinent questions regarding me or my computer will be answered, outputs from config files can be accessed and posted (IDK which ones or what parts to post).

share|improve this question
+1 this is very well researched. Two questions that may help: 1) Have you tried the Flash-Aid plugin for FireFox? 2) Does @gajdipajti's answer here help at all? If neither of these help, you may want to focus on troubleshooting why the proprietary graphics driver won't activate. That may be the root cause here. Good luck. – Tom Brossman Sep 16 '12 at 8:14
I just tried Flash-Aid, and sadly it did not resolve my issue. However, it looks like a very handy utility for use on other machines so thanks for telling me about it. I will try reading the thread you linked to next - my morale benefits from doing one thing at a time. – sparthikas Sep 16 '12 at 20:47
OK I just took a crack at following the linked thread, and first realized that before downloading and installing the earlier version (which I think has a good chance of helping, as this system ran flash fine in earlier times) I should remove the flash-aid installed version. Flash Aid has no option to skip installation and perform only a removal, so I started to search how to do so manually. After 10 or so minutes of searching fruitlessly (all the methods were for older versions, other/older linux, or seemed incomplete) I came back to the thread to see if the instructions performed removal - – sparthikas Sep 16 '12 at 21:03
they did not, and as I scrolled down I saw a post which claims the older version is no longer available (which is the problem I've run into trying to find old, specific, versions) and the download path comes back 404'd. I gotta take a break from this for now, but thanks for the help I'm not giving up. – sparthikas Sep 16 '12 at 21:05
OK back at it, went back over to the linked thread and gave it a more thorough looking-over. Followed gajdipajti's second set of instructions for acquiring the tar.gz file, then had to do a filesystem search for after discovering /usr/lib/flashplugin-installer doesn't exist, found in /usr/lib/mozilla/plugins. Used sudo cp in terminal to replace it with the new (old) one, lucky I can recognize a symlink - and know that i didn't have to replace that too (or instead). FLASH NOW WORKS, or at least I played a youtube video. IDK if I'll bother messing with my driver or not.TYVM! – sparthikas Sep 17 '12 at 2:12
up vote 2 down vote accepted

ALRIGHTY THEN my issue is fully resolved and I'll walk us through it. The graphics card driver is moot, unimportant, and otherwise not related. I have no need to tinker with it at this time.

Based on the report on the linked thread that Flash 11.2 does not work with Athlon XP 1600+, I will venture to say that it does not work with my Athlon XP 2800+. So I downloaded Flash 10.3, and it worked. Not satisfied to stop there, I tried Flash 11.1 and it also works. To summarize:


I confirmed that it worked on youtube and hulu and that fullscreening caused no additional problems (a while back fullscreening would make vids play choppily). I'm new here so I don't know if I can retroactively change the topic flags to reflect the fact that it is the CPU we are concerned with, and not drivers at all - but I'll try. Thank you and good night.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.