Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I couldn't find an answer for this, so I thought I would try here.

My problem is, I have some games on Wine that play in full screen mode but I can't really get them in full screen mode. When they start up, they end up with the GUI's "HUD" overlapping the game which is really annoying and well kills the option to play the game. This has also happened in a few of my Linux programs as well. While I wrote its a problem with Unity, it really isn't limited to this though. I've done full screen mode on Unity and had the Unity side bar and top menu overlap, I've used Gnome and had the same issue happen, Gnome menu is in the top, Cinnamon had the same issue.

Sometimes if I Alt-Tab out of it and back into the program it MIGHT remove the HUD but that doesn't always work, and lets face it, full screen mode that is killed by the GUI just isn't something that can really be ignored.

Any suggestions or help would be highly welcomed.

My laptop http://www.cnet.com/laptops/asus-g53jw-a1-15/4507-3121_7-34210244.html

edit

Seems so far to be an issue with Unity and Gnome being in 3D mode, and possibly an issue with my NVidia card and XServe (I think that was it...). Going to Unity/Gnome 2d modes seem to help with this for the moment...

share|improve this question
add comment

1 Answer 1

I take it you're using the HUD to start the game, and it's not closing properly and is overlaying the full-screen game?

Try a different method of start the game if possible, such as pinning it to the launcher and starting it that way. Perhaps this answered question may be helpful:

How does one create a custom application launcher for Wine installed apps?

You might also try running the game in a VM instead of Wine. Oracle's VirtualBox is great and the free version is in the repositories, though you might want to get the PUEL (personal use evaluation license) version from Oracle for the USB 2.0 support and great full screen mode (looks like a Windows machine, no borders, no menus).

share|improve this answer
    
No, I was using PlayOnLinux to launch my Wine games. And I have now tried playing Torchlight by both from the HUD and from the menu in the search area. In Torchlights case, it forces the screen into a 640x480 mode and blacks out the rest of the desktop. Like I can pan around but its all blacked out (everything still works). And the HUD still shows up and on top of it now, the game's 640x480 (I'm guessing its native setting) doesn't start in that window so I'm missing the right and bottom parts. –  Xatolos Sep 20 '12 at 0:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.