Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How to control gnome's auto mounting capabilities?

Whenever I have a Gnome session opened (doesn't apply when no X session is active) some actions are taken when a CD-ROM is inserted or a USB drive is attached.

Where's the configuration for that?

share|improve this question

6 Answers 6

GNOME automounting capabilities are managed by Nautilus, the default GNOME file manager.

Nautilus also manage the desktop icons and other aspects, as automounting, and runs at startup to do its job even if you don't know. To be convinved, run at startup:

enzotib@compaq:~$ pgrep -l nautilus
1678 nautilus
2362 nautilus
enzotib@compaq:~$ 

To control what it happens when a CDROM is inserted, or an external HD, or a flash memory, start Nautilus and go to System -> Preferences menu item and select the last tab, Media. Here you can control many aspect of automounting.

share|improve this answer

open Nautilus and go to edit/preferences and then you want the media tab

share|improve this answer
    
Hmmm... I don't use Nautilus at all, but opened that one. And I have everything disabled at Edit/preferences. Still something happens on 'inserting media'. The only checkbox I have is 'never prompt or start programs on media insertion'. –  Grzegorz Oledzki Dec 26 '10 at 20:19
3  
you should give more detail on what to do once in the media tab, otherwise the answer is useless :/ –  RolandiXor Jan 14 '11 at 18:05

It depends on what you want to do. Options that are spelled out in /etc/fstab will take precedence over FUSE (I don't know much about FUSE, and I'm assuming that it's the thing that does the automounting magic for GNOME). For example, I had a second hard disk that needed the "user" and "noauto" options (I didn't want it automounting) and adding its entry to /etc/fstab worked.

I don't know how long this will continue to work, since the trend now seems to be to allow the automatic tools "guessing" the user's intent to overwrite configurations explicitly set by the user (for example, nm-applet overwriting /etc/network/interfaces).

share|improve this answer
    
I wanted to configure the automounting feature, incl. the permissions, ownership of mounts & created directories under /media. I wanted to turn off the automount feature for CDROMs at all, because it's causing a problem with my CD tray (it won't stay open for more than half a second), etc. If the gnome automounting capabilities don't provide enough configurability, I would like to turn it off completely and have the automount features set up in a different way (which shouldn't be a problem). –  Grzegorz Oledzki Dec 27 '10 at 20:15
1  
fuse has nothing to do with GNOME automounting, that is managed by nautilus. –  enzotib May 21 '11 at 7:11

From https://help.ubuntu.com:

Go to System->Administration->User and Groups, choose the user, click on
"Properties", then go to the "User Privileges" tab. You should have the 
"Access external storage devices automatically" option
share|improve this answer

All of you suggesting it's done by Nautilus - you're right.

I found a solution to my problem in the gconf-editor configuration utility. Opened it, navigated to /apps/nautilus/preferences/media_automount and turned it off. And bang! Now no automounting happens.

enter image description here

share|improve this answer

On Ubuntu 12.10 with Gnome Shell 3.6.2 there is a Tab under System Settings / Details.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.