Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm working on overclocking my rig right now, but I need to know the cpu frequency from within Ubuntu. I've figured out that I have to run a stress test while preforming the following commands to get a "accurate" reading, but they still only record stock speed. I've tried sudo cat /proc/cpuinfo but that shows my CPU cores running at 800MHz. I've looked in System Information but both report my cores running at 2900.00MHz, when the BIOS reports my poor overclocking skills coming in at roughly 3100.00MHz.

After a reboot and overclocking my CPU another 200MHz, both tools now report 3200.0MHz when my BIOS says its just above 3400.00MHz. The tools don't report the stock speed, but I doubt they're reporting the real speed, they're about 200MHz low.

What am I doing wrong, why are these tools only reporting my stock settings?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Incidentally, you can see the available CPU frequencies using:

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_available_frequencies

..the maximum frequencies using:

cat /sys/devices/system/cpu/cpu*/cpufreq/cpuinfo_max_freq

and the current CPU frequencies using:

cat /sys/devices/system/cpu/cpu*/cpufreq/cpuinfo_cur_freq
share|improve this answer
    
I'll look into this when I get the computer back up online. –  John Sep 16 '12 at 19:41

Try i7z http://code.google.com/p/i7z/ if you are using an Intel i3, i5, or i7 CPU. It shows the actual current CPU frequency, even if you have overclocked it using the BIOS.

As you mention in your question, to see the overclocked speed you'll have to run a job that pushes at least one core, or you'll only see a much lower idle frequency in i7z.

share|improve this answer

Looking under BIOS settings, I disabled all CPU "extras", and I was rewarded with the right frequency. I then enabled everything one by one until I found the culprit - AMD PowerNow feature. Disabling it fixed my frequency issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.