Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Previously linuxant release driver for conexant modem (HCF or HSF), now for newer kernel this site doesn't release for newer kernel version (after 2.6.31-17 version). how to use conexant modem in Ubuntu with newer Kernel than 2.6.31-17 (... , 10.4 , ...)?

Linuxant Ubuntu driver :

share|improve this question

2 Answers 2

up vote 2 down vote accepted

There is a compile-it-yourself option. See here.

Download the tar and then follow METHOD C on the installation instructions.

Following your comment, I decided to try building it. It went fine. Here's what I did:

  • Download and extract the tar for the right arch.
  • cd into the new directory and then

    sudo make debprecomp
  • Assuming everything worked, there should be a .deb file sitting in the directory above the current working dir. Just double-click it and it should install.

After that just follow the rest of the installation instructions.

share|improve this answer
Are you sure that this way work on newer version of kernel like 2.6.31 ? – SjB Aug 11 '10 at 11:05
No but you can easily find out. – Oli Aug 11 '10 at 12:42
Well I just built it fine. I don't have an applicable modem so I can't test if it works. I'm using the mainline 2.6.35 so I assume it should build for things in between .31 and .35 too. – Oli Aug 11 '10 at 12:46

Also Dell provide this driver. I have used it long time ago.

Try this page or looking for similar items on dell support.

share|improve this answer
I need this driver for newer version of kernel – SjB Aug 11 '10 at 10:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.