Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to get HDMI output using a Gainward Nvidia 210 512 MB on Ubuntu 10.04 Lucid Lynx.

I have upgraded alsa-driver, alsa-lib and alsa-utils to 1.0.24 by building from source, thanks to this blog post.

After i use aplay -l on terminal, it says:

user@box:~$ lspci | grep Audio
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
01:09.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
01:09.2 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
01:09.4 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [IR Port] (rev 05)
02:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)


user@box:~$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.24.
Compiled on Sep 15 2012 for kernel 2.6.32-42-generic (SMP).


user@box:~$ ls /proc/asound`
card0  cards    hwdep    NVidia    oss  seq     version
card1  devices  modules  NVidia_1  pcm  timers


user@box:~$ aplay -l
aplay: device_list:240: no soundcards found...


user@box:~$ sudo /sbin/alsa-utils start
 * Setting up ALSA...
 * warning: 'alsactl restore' failed with error message 'alsactl: set_control:1403:
Cannot write control '2:0:0:IEC958 Playback Default:0' : Operation not permitted'...
amixer: Invalid command!
...done.

Any help appreciated.

PS my video card is connected only through the PCI-E slot. I assume there is no extra audio connection required.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

1.0.24 is quite old; you should at least use the 1.0.25 driver package.

Your aplay/amixer problems sound as if you have permission problems. Check that your user is in a group that has access to the device nodes in /dev/snd/.

share|improve this answer
1  
I'll accept this answer, as it's probably the right sort of suggestion. I cured it in the end by simply moving to 12.04LTS, which brought me kicking and screaming into the present. –  nimasmi Sep 22 '12 at 11:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.