Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Xubuntu. I was running headless fine before using tightVNC on windows and vino on Xubuntu. Now, after entering the password on the remote server, the following dialog pops on the local server (the one that usually don't have a monitor) before open the connection :

Enter password for keyring Default to unlock

Why is that dialog showing?

How do I get ride of it?

share|improve this question
    
It seem to be a bug in vino server bugs.launchpad.net/ubuntu/+source/vino/+bug/562423, a bad decision from a package manager. –  Guillaume Coté Dec 26 '10 at 14:43
    
The issue is the password can be saved in the keyring or somewhere else. The default was changed to save it in the keyring. –  Guillaume Coté Dec 26 '10 at 15:07
    
Try this –  karthick87 Dec 26 '10 at 19:17
    
My vino server was updated in October 2009, and it work fine until yesterday. I try to reset the password on the command line a month ago (which failed, I borrow a monitor to reset it yesterday). I suspect this issue is related to a something I typed on the command line trying to reset the password. –  Guillaume Coté Dec 26 '10 at 20:19
add comment

5 Answers 5

up vote 3 down vote accepted

This is a known bug in the Debian/Ubuntu package of vino server. There is a workaround in the bug comments, which I'm reproducing here. Rumour says it's only good for 10.04.

  1. Open up Applications->Accessories->Passwords and Encryption Keys
  2. Right click Passwords:login and unlock it.
  3. You should be able to expand the tree and find a listing for vino. Right click and delete it.
  4. Close Passwords and Encryption Keys.
  5. Open gconf-editor as and navigate to /desktop/gnome/remote_access
  6. Enter in your BASE64 encoded password into the vnc_password key.
    • Run echo -n "your password" | base64. Enter the output, even the equal sign.
  7. Save the config and close the editor.
  8. Log out, log back in, and you can now use your VNC client to connect to your machine without being first prompted with the keyring.
share|improve this answer
    
Thanks for your answer. I am running Xubuntu, seem like Passwords and Encryption Keys is not there by default. I am installing and I'll try to test again. –  Guillaume Coté Mar 22 '11 at 2:36
    
The packages for Passwords and Encryption Keys is seahorse. –  Guillaume Coté Mar 23 '11 at 2:20
    
It works!!! Thanks –  Guillaume Coté Mar 23 '11 at 2:22
    
However, I would put the -n in bold, it's easy to forgot and necessary. –  Guillaume Coté Mar 23 '11 at 2:28
add comment

I have solved this problem. When you run vino-preferences, and check the box labeled Require the user to enter this password: the system will popup a menu asking for the default keyring.

It's easy, be sure to empty these fields, and accept the security warning that follows. Then write the viewer password as you want, reboot and you can connect without problems.

In the case you wrote something in these fields, you should remove the file: rm ~/.gnome2/keyrings/default.keyring then reboot and redo vino-preferences as I said before.

Hope this helps.

share|improve this answer
add comment

I'd say click on "Details" in that same window and choose to the first option saying something like "start keyring when i login". It's by far the simplest and safest choice.

It took me like 2 hours to find that simple solution, i wonder how many people click on that option...

share|improve this answer
add comment

The answer by @djeikyb did not work for me; when I did this, my VNC client could not connect (and I did use echo -n to base64 encode my password.)

Instead, I stopped vino-server, restored my ~/.gconf/desktop/gnome/remote_access/%gconf.xml (to undo the change completely), ran vino-preferences (from a console) and entered my connection password in the preferences dialog, then logged off/logged back in (which restarts my vino-sever).

My 'login' password is the default (in seahorse), and my 'default' keyring does not have a vino entry.

Now my client can connect and I don't have to unlock my keyring.

(Note: I'm running the latest update for vino-server on Ubuntu 11.10; I think some bugs have been fixed in vino)

share|improve this answer
add comment

there is no Passwords and Encryption in Xubuntu menus . you should manualy add this .

your Solution is Here :

 http://www.geekyeric.com/?p=67
share|improve this answer
2  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  hexafraction Oct 8 '12 at 17:04
    
link goes nowhere now –  Chris Cleeland Jan 6 at 19:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.