Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using ubuntu 10.10 and am currently trying out different players. I started with the default player (Rhythmbox) however ran into issues..click here to view it. So I then decided to try out banshee (V1.9.1) which worked perfectly getting all my album covers and nicely integrating with the sound menu.

However few hours later, banshee is still shown in the sound menu but when it plays a song it does not update the sound menu. It can be seen in the screenshot below. As you can see the song is being played at the moment but in the sound menu the play buttons and song are not displayed. So indeed the sound menu plugin for banshee is installed by default.

Also when I click the close button, banshee closes completely, normally it does close but the song plays in the background and can be controlled via the sound menu. To completely close it I had to click Ctrl + Q.

It was working all perfectly and then suddenly I have this issue. I have no idea on where to start troubleshooting..Can anyone help me?

alt text

To answer the comments and answers below,

  1. Restarting did not help.

  2. From V1.9.1 banshee made the sound menu plugin as a core plugin which is thereby installed by default and enabled. However for some reason I do not see this plugin in my extensions list. I tried reinstalling it two times and purging all configuration files but still have the same problem. I restarted after every install and uninstall of banshee.

Although I must say this, before I unchecked certain extensions like the ipod/ipad extension (however not the sound menu extension) and those choices that I made were visible even when I uninstalled and installed banshee again. I have a feeling that the old configuration files of banshee were not completely purged.

Is there a way to purge banshee completely? I mean everything and do a clean install of Banshee in the hope that this solves the problem?

share|improve this question
    
It may sound silly, but try a logout/login (or restart) –  fluteflute Dec 26 '10 at 15:17
add comment

2 Answers

Go to preferences -> Extensions and enable Sound menu integration for Banshee

share|improve this answer
    
In a way I did what you asked. :) –  nik90 Dec 26 '10 at 22:27
add comment
up vote 0 down vote accepted

As mentioned in the question, the banshee Version 1.9.1 does indeed come with the sound menu extension as a core plugin. However for some unknown reason it is not present in my core plugin list as can be seen in the screenshot.

So what I did was, I installed the sound menu extension manually from the community extensions (downloaded from an article in omgubuntu.co.uk, click here to view it.)

I know this is not the proper way to solve the problem as I am yet to find out why the sound menu core plugin was removed or not there, but I intend to look for the reason meanwhile.

alt text

share|improve this answer
    
I am so glad to finally fix this problem for now...!!! :) –  nik90 Dec 26 '10 at 22:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.