Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I sometimes connect to a defective wireless AP in my office, whose 802.11n is somehow faulty. My Maverick netbook has an atheros AR9285 wireless, which supports 802.11n and wants to connect the AP with 802.11n, failing.

I managed to fix the thing in Windows by disabling the 802.11n mode and enabling only 802.11b/g. Is there a way to do the same in Maverick?

share|improve this question
    
+1 - Hilarious that 2.5 years later, I too want to disable 11n in my Ath9k card for the same reason. –  Geoff May 31 '13 at 19:14

1 Answer 1

up vote 4 down vote accepted

Researching here on the linux kernel wireless page for your driver the 'ath9k' shows:

http://wireless.kernel.org/en/users/Drivers/ath9k

That there is no way to switch off 802.11n support for this driver, not unless you modified the code and recompiled. You should report the issue of this missing feature here:

https://bugzilla.kernel.org/buglist.cgi?query_format=specific&order=relevance+desc&product=&content=ath9k

This guy here shows how he disabled 802.11n in ath9k, but it might be a little hard to do:

http://permalink.gmane.org/gmane.linux.drivers.ath9k.devel/1645

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.