Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had removed network-manager as soon as I installed Ubuntu 10.04.

Earlier I used to do the following to connect (successfully) on command line:
iwconfig eth2 essid NASA
dhclient eth2

Now that WPA2 encryption is enabled, I tried this, but failed:
iwconfig eth2 essid NASA key hunter2
dhclient eth2

with error:
Error for wireless request "Set Encode" (8B2A) : invalid argument "hunter2"

Where am I going wrong?

lspci gives:
02:00.0 Network controller: Broadcom Corporation Device 4727 (rev 01)

lshw -C network gives:

*-network
description: Wireless interface
product: Broadcom Corporation
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:02:00.0
logical name: eth2
version: 01
serial: 78:e4:00:2e:54:28
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=wl0 driverversion=5.60.48.36 ip=192.1.0.20 latency=0 multicast=yes wireless=IEEE 802.11
resources: irq:17 memory:56000000-56003fff

Edit 1: As suggested by CYREX, I tried WPA directions given in:
http://ubuntuforums.org/showthread.php?t=571188
In the command:
sudo wpa_supplicant -D wext -i eth2 -c /etc/wpa_supplicant.conf
I used wext as the driver.

When I run this command, the following happens:
Trying to associate with 00:24:b2:39:f4:c6 (SSID='NASA' freq=2462 MHz) ioctl[SIOCSIWAP]: Device or resource busy
Association request to the driver failed
Associated with 00:1b:2f:a8:da:cc
WPA: Key negotiation completed with 00:1b:2f:a8:da:cc
[PTK=TKIP GTK=TKIP] CTRL-EVENT-CONNECTED - Connection to 00:1b:2f:a8:da:cc
completed (auth) [id=0 id_str=]

I tried both his WPA1 and WPA2 stuff. In either case iwconfig eth2 gives Encryption key: off.

share|improve this question

closed as too localized by htorque, jokerdino, Takkat, Bruno Pereira Feb 26 '12 at 11:10

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be abandoned as there hasn't been any activity for a longer period of time. I'm voting to close it for now. If by any reason you think this question is still viable or useful in anyways or that there is still a good chance it will be answered please flag it to a moderator or add a comment with the reasons why you want it reopened. Thanks! –  htorque Feb 23 '12 at 18:34

1 Answer 1

I made this one: how to connect to wireless network manually (in terminal) without using network manager?

But i think it won't work since i later found out that when you put a WPA key, the whole thing gets a "little" complicated. Not so easy as iwconfi wlan0 key s:password for like WEP security. I then found out this HUGE post which has in detail information that worked in my case for WPA and WPA2 using PSK (At least in my case) I hope it helps you too:

http://ubuntuforums.org/showthread.php?t=571188

NOTE: Make sure your card supports WPA. Happen to one of my students that he spend a week trying this and it did not work since his card did not support WPA (It did not even have anything WPA related).

More Specific link about WPA2 -> http://ubuntuforums.org/showthread.php?t=607410 Good luck, let me know how it went.

share|improve this answer
    
I tried WPA directions given in: ubuntuforums.org/showthread.php?t=571188 In the command: sudo wpa_supplicant -D wext -i eth2 -c /etc/wpa_supplicant.conf I used wext as the driver. When I run this command, the following happens: Trying to associate with 00:24:b2:39:f4:c6 (SSID='NASA' freq=2462 MHz) ioctl[SIOCSIWAP]: Device or resource busy Association request to the driver failed Associated with 00:1b:2f:a8:da:cc WPA: Key negotiation completed with 00:1b:2f:a8:da:cc [PTK=TKIP GTK=TKIP] CTRL-EVENT-CONNECTED - Connection to 00:1b:2f:a8:da:cc completed (auth) [id=0 id_str=] –  user7914 Dec 26 '10 at 9:08
    
BTW, I tried both his WPA1 and WPA2 stuff. In either case iwconfig eth2 gives Encryption key: off. –  user7914 Dec 26 '10 at 9:15
1  
@avinash Add all this information to your question please so it doesn't get buried in the comments. –  Jorge Castro Dec 26 '10 at 16:31
    
@Jorge : Added, thanks. –  user7914 Dec 26 '10 at 16:59
    
@Luis Alvardo thanks for making these guides I was searching for some information and reached your hard work –  Registered User Oct 10 '13 at 23:42