Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got Ubuntu 12.04.1, but Unity is still in the 5.14 version. I have a problem with the launcher tooltips, but it got fixed in Unity 5.16. How can I update it? I've tried adding ppa:unity-team/ppa, ppa:unity-team/stagging and ppa:ubuntu-desktop/ppa, but nothing worked. Please, I hope you can help me!

The bug is: https://bugs.launchpad.net/unity/+bug/1034164

Here's something I found about Unity 5.16, but I don't know how launchpad works so much, but if i'm not wrong I think there's some way to install it: https://launchpad.net/ubuntu/+source/unity/5.16.0-0ubuntu1

I tried enabling the purposed source at Software Origins but, after creating the preferences file at /etc/apt for making it selective as i read, I tried apt-get update and upgrade, but nothing was updated.

share|improve this question
    
Ok, it seems as I fixed it with the ppa:unity-team/sru, I did apt-get update && upgrade, but after that I went to the Updates Manager and unity and other packages appeared there for update, I updated and now it's fixed! I have to test it in a new installation because I did somethings here as echo "unity install" | dpkg --set-selections and installed the stagging PPA also! –  Addison Montgomery Sep 15 '12 at 18:41
add comment

1 Answer 1

up vote 0 down vote accepted

The bug fix has been committed but not released yet, so sort of building it yourself the fix for that bug isn't available yet. You can try it by enabling the proposed repository:

See also here:

share|improve this answer
    
Thanks for answering, but I looked here: launchpad.net/ubuntu/+source/unity/5.16.0-0ubuntu1, it seems as it's purposed and there should be any way to update to unity 5.16? –  Addison Montgomery Sep 15 '12 at 17:44
    
@Bousie updated! –  Jorge Castro Sep 15 '12 at 23:26
    
Thanks! The think about it was that I didn't want to update all my packages to the purposed version, only Unity. But, at the moment, it worked for me just with the SRU PPA, but I'll try to use the proposed if I reinstall someday :) –  Addison Montgomery Sep 16 '12 at 10:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.