Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I run mlnet, it gives: Attention! This core is running with glibc 2.15 but it was compiled with glibc 2.13. This can lead to unexpected behaviour. Consider compiling the core yourself or getting a binary compiled with glibc 2.13.

How to do with it ? Thanks

share|improve this question

I've found the same problem, and I have fixed it checking on the .log file in .MLDonkey directory. I had a problem with this file: "stats_mod.ini.tmp". I deleted that file, then MLNet works again :)

share|improve this answer

Not sure how you installed mldonkey but I would try and download mldonkey by entering the following command:

sudo apt-get install mldonkey-gui

This should get it working for you.

share|improve this answer

I ran into the same problem with Ubuntu 14.04 where MLDonkey Core is compiled with glibc 2.18 but running with glibc 2.19. You can compile and install the package again to solve this problem.

sudo apt install debian-keyring dpkg-dev
sudo apt-get build-dep mldonkey-server
apt-get source --compile mldonkey-server
sudo dpkg -i mldonkey-<Tab>.deb

The first line is needed to check package signatures and uncompress source packages. The second line installs compilers and headers to compile mldonkey. The third line downloads the source and creates the package. The fourth line installs the new package (press Tab to autocomplete the filename as the filename will depends on mldonkey version). You can then delete all mldonkey* files and folders in the current folder.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.