Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When is loading and two monitors are connected, instead of a login screen I see this: enter image description here

...after clicking OK, selection appears: enter image description here

Then I'm following to console login, disconnecting by hand the secondary monitor cable, restart lightdm with a command

sudo service lightdm restart

...and voila! System loads fine. If I disconnect the cable before boot X will be loaded fine too.

It's not a nice 'feature' when I have to disconnect the cable each boot or X restart.

I was trying to delete monitors.xml but it didn't help.

The situation relates to my notebook with Intel integrated GPU. The same happens on two different pairs of monitors: at the office and at home.

How can I fix this?

Ubuntu 12.04 x64 Desktop with default Unity GUI.

share|improve this question
add comment

1 Answer

I had the same issue ever since I bought two external monitors for my System76 laptop. A System76 representative in the Ubuntu Forums said the laptop supports dual external screens, but not all three at the same time (third being the laptop's display). I finally resolved the issue by forcing Xorg to "ignore" the laptop screen.

You'll need to create an xorg.conf file using these instructions: https://fedoraproject.org/wiki/How_to_create_xorg.conf. Move it to /etc/X11/xorg.conf. Open a terminal, run xrandr and look at what your device names are. Mine were LVSD1, HDMI1 and VGA1. In xorg.conf, make the following changes:

In Section "Device", add an option line for each output device from xrandr. Mine are:

Option "Monitor-LVDS1" "MonitorLaptop"
Option "Monitor-HDMI1" "MonitorHDMI"
Option "Monitor-VGA1" "MonitorVGA"

The left side is "Monitor-" then the name from xrandr. The right side is what we refer to it as in xorg.conf.

Next, make sure you have 3 monitor sections. Configure them like this:

Section "Monitor"
    Identifier      "MonitorLaptop"
    Option          "Ignore" "true"
EndSection

Section "Monitor"
    Identifier      "MonitorHDMI"
    Option          "Enable" "true"
EndSection

Section "Monitor"
    Identifier      "MonitorVGA"
    Option          "Enable" "true"
EndSection

And two screen sections like this:

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "MonitorHDMI"
EndSection

Section "Screen"
    Identifier "Screen1"
    Device     "Card0"
    Monitor    "MonitorVGA"
EndSection

And finally, in the ServerLayout section, you should have two Screen settings:

Screen         "Screen0"
Screen         "Screen1" RightOf "Screen0"

Reboot and cross your fingers :D

Note that this configuration will also disable your laptop screen even if no other monitors are plugged in, so in that situation you'll need to boot into recovery mode (hold right shift while booting), rename your xorg.conf to something else and reboot again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.