Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to force my native display resolution of 1920x1080 although no EDID information is available. My desktop is hooked up to a VGA switch and is therefore unable to query the EDID (it works fine without the switch). All attempts to force X to use the native resolution failed. The resolution always drops to the nvidia-auto-select which selects a mode from the predefined mode pool. Custom modes are ignored without any error. I also tried UseEDID instead of ÌgnoreEDID in the device and screen section. I'm using a nvidia 430 with the nvidia driver. Below is my xorg.conf

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Modeline "1920x1080_new" 148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync
    Option   "Preferred Mode"        "1920x1080_new"
    Option   "ExactModeTimingsDVI" "True"               
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    Option     "UseEDIDFreqs"   "False"
    Option     "UseEDIDDpi"     "False"
     Option    "IgnoreEDID"     "True"
    Option     "ModeValidation" "NoVesaModes,NoXServerModes,NoEDIDModes"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option      "MetaModes" "1920x1080_new"
    SubSection     "Display"
    Depth       24
    Modes      "1920x1080_new"
    EndSubSection
EndSection

Here is the xlog with the switch. I also tried another switch with the same result.

[  1402.712] 
X.Org X Server 1.11.3
Release Date: 2011-12-16
[  1402.712] X Protocol Version 11, Revision 0
[  1402.712] Build Operating System: Linux 2.6.42-26-generic i686 Ubuntu
[  1402.712] Current Operating System: Linux desktopAW 3.2.0-30-generic-pae #48-Ubuntu SMP Fri Aug 24 17:14:09 UTC 2012 i686
[  1402.712] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-30-generic-pae root=UUID=280c1a92-ec50-4b1a-828c-c8fac158e875 ro quiet splash
[  1402.712] Build Date: 04 August 2012  01:51:24AM
[  1402.712] xorg-server 2:1.11.4-0ubuntu10.7 (For technical support please see http://www.ubuntu.com/support) 
[  1402.712] Current version of pixman: 0.24.4
[  1402.712]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[  1402.712] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1402.712] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Sep 15 12:40:36 2012
[  1402.713] (==) Using config file: "/etc/X11/xorg.conf"
[  1402.713] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1402.713] (==) No Layout section.  Using the first Screen section.
[  1402.713] (**) |-->Screen "My Screen" (0)
[  1402.713] (**) |   |-->Monitor "<default monitor>"
[  1402.713] (==) No device specified for screen "My Screen".
    Using the first device section listed.
[  1402.713] (**) |   |-->Device "My Card"
[  1402.713] (==) No monitor specified for screen "My Screen".
    Using a default monitor configuration.
[  1402.713] (==) Automatically adding devices
[  1402.713] (==) Automatically enabling devices
[  1402.713] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  1402.713]    Entry deleted from font path.
[  1402.713] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[  1402.714]    Entry deleted from font path.
[  1402.714] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[  1402.714]    Entry deleted from font path.
[  1402.714] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[  1402.714]    Entry deleted from font path.
[  1402.714] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[  1402.714]    Entry deleted from font path.
[  1402.714] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/Type1,
    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    built-ins
[  1402.714] (==) ModulePath set to "/usr/lib/i386-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[  1402.714] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[  1402.714] (II) Loader magic: 0xb77ef5a0
[  1402.714] (II) Module ABI versions:
[  1402.714]    X.Org ANSI C Emulation: 0.4
[  1402.714]    X.Org Video Driver: 11.0
[  1402.714]    X.Org XInput driver : 16.0
[  1402.714]    X.Org Server Extension : 6.0
[  1402.714] (--) PCI:*(0:2:0:0) 10de:0de1:3842:1335 rev 161, Mem @ 0xf8000000/16777216, 0xe8000000/134217728, 0xf0000000/33554432, I/O @ 0x0000a000/128, BIOS @ 0x????????/524288
[  1402.714] (II) Open ACPI successful (/var/run/acpid.socket)
[  1402.714] (II) LoadModule: "extmod"
[  1402.715] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[  1402.715] (II) Module extmod: vendor="X.Org Foundation"
[  1402.715]    compiled for 1.11.3, module version = 1.0.0
[  1402.715]    Module class: X.Org Server Extension
[  1402.715]    ABI class: X.Org Server Extension, version 6.0
[  1402.715] (II) Loading extension MIT-SCREEN-SAVER
[  1402.715] (II) Loading extension XFree86-VidModeExtension
[  1402.715] (II) Loading extension XFree86-DGA
[  1402.715] (II) Loading extension DPMS
[  1402.715] (II) Loading extension XVideo
[  1402.715] (II) Loading extension XVideo-MotionCompensation
[  1402.715] (II) Loading extension X-Resource
[  1402.715] (II) LoadModule: "dbe"
[  1402.715] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[  1402.716] (II) Module dbe: vendor="X.Org Foundation"
[  1402.716]    compiled for 1.11.3, module version = 1.0.0
[  1402.716]    Module class: X.Org Server Extension
[  1402.716]    ABI class: X.Org Server Extension, version 6.0
[  1402.716] (II) Loading extension DOUBLE-BUFFER
[  1402.716] (II) LoadModule: "glx"
[  1402.716] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/libglx.so
[  1402.753] (II) Module glx: vendor="NVIDIA Corporation"
[  1402.753]    compiled for 4.0.2, module version = 1.0.0
[  1402.753]    Module class: X.Org Server Extension
[  1402.753] (II) NVIDIA GLX Module  295.40  Thu Apr  5 21:49:54 PDT 2012
[  1402.753] (II) Loading extension GLX
[  1402.753] (II) LoadModule: "record"
[  1402.754] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[  1402.754] (II) Module record: vendor="X.Org Foundation"
[  1402.754]    compiled for 1.11.3, module version = 1.13.0
[  1402.754]    Module class: X.Org Server Extension
[  1402.754]    ABI class: X.Org Server Extension, version 6.0
[  1402.754] (II) Loading extension RECORD
[  1402.754] (II) LoadModule: "dri"
[  1402.754] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[  1402.754] (II) Module dri: vendor="X.Org Foundation"
[  1402.754]    compiled for 1.11.3, module version = 1.0.0
[  1402.754]    ABI class: X.Org Server Extension, version 6.0
[  1402.754] (II) Loading extension XFree86-DRI
[  1402.754] (II) LoadModule: "dri2"
[  1402.754] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[  1402.754] (II) Module dri2: vendor="X.Org Foundation"
[  1402.754]    compiled for 1.11.3, module version = 1.2.0
[  1402.754]    ABI class: X.Org Server Extension, version 6.0
[  1402.755] (II) Loading extension DRI2
[  1402.755] (II) LoadModule: "nvidia"
[  1402.755] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/nvidia_drv.so
[  1402.755] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1402.755]    compiled for 4.0.2, module version = 1.0.0
[  1402.755]    Module class: X.Org Video Driver
[  1402.755] (II) NVIDIA dlloader X Driver  295.40  Thu Apr  5 21:29:50 PDT 2012
[  1402.755] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1402.755] (++) using VT number 7

[  1402.757] (II) Loading sub module "fb"
[  1402.757] (II) LoadModule: "fb"
[  1402.757] (II) Loading /usr/lib/xorg/modules/libfb.so
[  1402.758] (II) Module fb: vendor="X.Org Foundation"
[  1402.758]    compiled for 1.11.3, module version = 1.0.0
[  1402.758]    ABI class: X.Org ANSI C Emulation, version 0.4
[  1402.758] (II) Loading sub module "wfb"
[  1402.758] (II) LoadModule: "wfb"
[  1402.758] (II) Loading /usr/lib/xorg/modules/libwfb.so
[  1402.758] (II) Module wfb: vendor="X.Org Foundation"
[  1402.758]    compiled for 1.11.3, module version = 1.0.0
[  1402.758]    ABI class: X.Org ANSI C Emulation, version 0.4
[  1402.758] (II) Loading sub module "ramdac"
[  1402.758] (II) LoadModule: "ramdac"
[  1402.758] (II) Module "ramdac" already built-in
[  1402.758] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/nvidia_drv.so
[  1402.758] (II) Loading /usr/lib/xorg/modules/libwfb.so
[  1402.758] (II) Loading /usr/lib/xorg/modules/libfb.so
[  1402.758] (II) NVIDIA(0): Creating default Display subsection in Screen section
    "My Screen" for depth/fbbpp 24/32
[  1402.758] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[  1402.758] (==) NVIDIA(0): RGB weight 888
[  1402.758] (==) NVIDIA(0): Default visual is TrueColor
[  1402.758] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  1402.758] (**) NVIDIA(0): Option "NoLogo" "True"
[  1402.759] (**) NVIDIA(0): Option "RegistryDwords" "EnableBrightnessControl=1"
[  1402.759] (**) NVIDIA(0): Enabling 2D acceleration
[  1403.579] (WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-1
[  1403.581] (II) NVIDIA(0): NVIDIA GPU GeForce GT 430 (GF108) at PCI:2:0:0 (GPU-0)
[  1403.581] (--) NVIDIA(0): Memory: 1048576 kBytes
[  1403.581] (--) NVIDIA(0): VideoBIOS: 70.08.29.00.40
[  1403.581] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[  1403.581] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[  1403.582] (--) NVIDIA(0): Connected display device(s) on GeForce GT 430 at PCI:2:0:0
[  1403.583] (--) NVIDIA(0):     CRT-1
[  1403.583] (--) NVIDIA(0): CRT-1: 320.0 MHz maximum pixel clock
[  1403.592] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[  1403.592] (**) NVIDIA(0):     device CRT-1 (Using EDID frequencies has been enabled on
[  1403.592] (**) NVIDIA(0):     all display devices.)
[  1403.596] (II) NVIDIA(0): Assigned Display Device: CRT-1
[  1403.597] (==) NVIDIA(0): 
[  1403.597] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[  1403.597] (==) NVIDIA(0):     will be used as the requested mode.
[  1403.597] (==) NVIDIA(0): 
[  1403.597] (II) NVIDIA(0): Validated modes:
[  1403.597] (II) NVIDIA(0):     "nvidia-auto-select"
[  1403.597] (II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
[  1403.621] (WW) NVIDIA(0): Unable to get display device CRT-1's EDID; cannot compute DPI
[  1403.621] (WW) NVIDIA(0):     from CRT-1's EDID.
[  1403.621] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[  1403.621] (--) Depth 24 pixmap format is 32 bpp
[  1403.621] (II) NVIDIA: Using 1024.00 MB of virtual memory for indirect memory
[  1403.621] (II) NVIDIA:     access.
[  1403.626] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[  1403.650] (II) Loading extension NV-GLX
[  1403.710] (==) NVIDIA(0): Disabling shared memory pixmaps
[  1403.710] (==) NVIDIA(0): Backing store disabled
[  1403.710] (==) NVIDIA(0): Silken mouse enabled
[  1403.710] (==) NVIDIA(0): DPMS enabled
[  1403.710] (II) Loading extension NV-CONTROL
[  1403.711] (II) Loading extension XINERAMA
[  1403.711] (II) Loading sub module "dri2"
[  1403.711] (II) LoadModule: "dri2"
[  1403.711] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[  1403.711] (II) Module dri2: vendor="X.Org Foundation"
[  1403.711]    compiled for 1.11.3, module version = 1.2.0
[  1403.711]    ABI class: X.Org Server Extension, version 6.0
[  1403.711] (II) NVIDIA(0): [DRI2] Setup complete
[  1403.711] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[  1403.711] (==) RandR enabled
[  1403.711] (II) Initializing built-in extension Generic Event Extension
[  1403.711] (II) Initializing built-in extension SHAPE
[  1403.711] (II) Initializing built-in extension MIT-SHM
[  1403.711] (II) Initializing built-in extension XInputExtension
[  1403.711] (II) Initializing built-in extension XTEST
[  1403.711] (II) Initializing built-in extension BIG-REQUESTS
[  1403.711] (II) Initializing built-in extension SYNC
[  1403.711] (II) Initializing built-in extension XKEYBOARD
[  1403.711] (II) Initializing built-in extension XC-MISC
[  1403.711] (II) Initializing built-in extension SECURITY
[  1403.711] (II) Initializing built-in extension XINERAMA
[  1403.711] (II) Initializing built-in extension XFIXES
[  1403.711] (II) Initializing built-in extension RENDER
[  1403.711] (II) Initializing built-in extension RANDR
[  1403.711] (II) Initializing built-in extension COMPOSITE
[  1403.711] (II) Initializing built-in extension DAMAGE
[  1403.714] (II) Initializing extension GLX
[  1403.741] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
[  1403.746] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[  1403.746] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  1403.746] (II) LoadModule: "evdev"
[  1403.746] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  1403.746] (II) Module evdev: vendor="X.Org Foundation"
[  1403.746]    compiled for 1.11.3, module version = 2.7.0
[  1403.746]    Module class: X.Org XInput Driver
[  1403.746]    ABI class: X.Org XInput driver, version 16.0
[  1403.746] (II) Using input driver 'evdev' for 'Power Button'
[  1403.746] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  1403.746] (**) Power Button: always reports core events
[  1403.746] (**) evdev: Power Button: Device: "/dev/input/event1"
[  1403.746] (--) evdev: Power Button: Vendor 0 Product 0x1
[  1403.746] (--) evdev: Power Button: Found keys
[  1403.746] (II) evdev: Power Button: Configuring as keyboard
[  1403.746] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[  1403.746] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[  1403.746] (**) Option "xkb_rules" "evdev"
[  1403.746] (**) Option "xkb_model" "pc105"
[  1403.746] (**) Option "xkb_layout" "de"
[  1403.749] (II) XKB: reuse xkmfile /var/lib/xkb/server-808BBA3D4C227BDB44C370226C34E44C5D69A4A9.xkm
[  1403.750] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[  1403.750] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  1403.750] (II) Using input driver 'evdev' for 'Power Button'
[  1403.750] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  1403.751] (**) Power Button: always reports core events
[  1403.751] (**) evdev: Power Button: Device: "/dev/input/event0"
[  1403.751] (--) evdev: Power Button: Vendor 0 Product 0x1
[  1403.751] (--) evdev: Power Button: Found keys
[  1403.751] (II) evdev: Power Button: Configuring as keyboard
[  1403.751] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[  1403.751] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[  1403.751] (**) Option "xkb_rules" "evdev"
[  1403.751] (**) Option "xkb_model" "pc105"
[  1403.751] (**) Option "xkb_layout" "de"
[  1403.751] (II) config/udev: Adding input device Razer Razer Diamondback 3G (/dev/input/event2)
[  1403.752] (**) Razer Razer Diamondback 3G: Applying InputClass "evdev pointer catchall"
[  1403.752] (II) Using input driver 'evdev' for 'Razer Razer Diamondback 3G'
[  1403.752] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  1403.752] (**) Razer Razer Diamondback 3G: always reports core events
[  1403.752] (**) evdev: Razer Razer Diamondback 3G: Device: "/dev/input/event2"
[  1403.752] (--) evdev: Razer Razer Diamondback 3G: Vendor 0x1532 Product 0xd
[  1403.752] (--) evdev: Razer Razer Diamondback 3G: Found 11 mouse buttons
[  1403.752] (--) evdev: Razer Razer Diamondback 3G: Found scroll wheel(s)
[  1403.752] (--) evdev: Razer Razer Diamondback 3G: Found relative axes
[  1403.752] (--) evdev: Razer Razer Diamondback 3G: Found x and y relative axes
[  1403.752] (II) evdev: Razer Razer Diamondback 3G: Configuring as mouse
[  1403.752] (II) evdev: Razer Razer Diamondback 3G: Adding scrollwheel support
[  1403.752] (**) evdev: Razer Razer Diamondback 3G: YAxisMapping: buttons 4 and 5
[  1403.752] (**) evdev: Razer Razer Diamondback 3G: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  1403.752] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:02.0/usb2/2-8/2-8:1.0/input/input2/event2"
[  1403.752] (II) XINPUT: Adding extended input device "Razer Razer Diamondback 3G" (type: MOUSE, id 8)
[  1403.752] (II) evdev: Razer Razer Diamondback 3G: initialized for relative axes.
[  1403.752] (**) Razer Razer Diamondback 3G: (accel) keeping acceleration scheme 1
[  1403.752] (**) Razer Razer Diamondback 3G: (accel) acceleration profile 0
[  1403.752] (**) Razer Razer Diamondback 3G: (accel) acceleration factor: 2.000
[  1403.752] (**) Razer Razer Diamondback 3G: (accel) acceleration threshold: 4
[  1403.753] (II) config/udev: Adding input device Razer Razer Diamondback 3G (/dev/input/mouse0)
[  1403.753] (II) No input driver specified, ignoring this device.
[  1403.753] (II) This device may have been added with another device file.
[  1403.753] (II) config/udev: Adding input device UVC Camera (046d:0804) (/dev/input/event5)
[  1403.753] (**) UVC Camera (046d:0804): Applying InputClass "evdev keyboard catchall"
[  1403.753] (II) Using input driver 'evdev' for 'UVC Camera (046d:0804)'
[  1403.753] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  1403.753] (**) UVC Camera (046d:0804): always reports core events
[  1403.753] (**) evdev: UVC Camera (046d:0804): Device: "/dev/input/event5"
[  1403.753] (--) evdev: UVC Camera (046d:0804): Vendor 0x46d Product 0x804
[  1403.753] (--) evdev: UVC Camera (046d:0804): Found keys
[  1403.753] (II) evdev: UVC Camera (046d:0804): Configuring as keyboard
[  1403.753] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:02.1/usb1/1-9/1-9.1/1-9.1:1.0/input/input5/event5"
[  1403.753] (II) XINPUT: Adding extended input device "UVC Camera (046d:0804)" (type: KEYBOARD, id 9)
[  1403.753] (**) Option "xkb_rules" "evdev"
[  1403.753] (**) Option "xkb_model" "pc105"
[  1403.753] (**) Option "xkb_layout" "de"
[  1403.754] (II) config/udev: Adding input device HID 046a:0023 (/dev/input/event3)
[  1403.754] (**) HID 046a:0023: Applying InputClass "evdev keyboard catchall"
[  1403.754] (II) Using input driver 'evdev' for 'HID 046a:0023'
[  1403.754] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  1403.754] (**) HID 046a:0023: always reports core events
[  1403.754] (**) evdev: HID 046a:0023: Device: "/dev/input/event3"
[  1403.754] (--) evdev: HID 046a:0023: Vendor 0x46a Product 0x23
[  1403.754] (--) evdev: HID 046a:0023: Found keys
[  1403.754] (II) evdev: HID 046a:0023: Configuring as keyboard
[  1403.754] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:02.1/usb1/1-9/1-9.4/1-9.4:1.0/input/input3/event3"
[  1403.754] (II) XINPUT: Adding extended input device "HID 046a:0023" (type: KEYBOARD, id 10)
[  1403.754] (**) Option "xkb_rules" "evdev"
[  1403.754] (**) Option "xkb_model" "pc105"
[  1403.754] (**) Option "xkb_layout" "de"
[  1403.755] (II) config/udev: Adding input device HID 046a:0023 (/dev/input/event4)
[  1403.755] (**) HID 046a:0023: Applying InputClass "evdev keyboard catchall"
[  1403.755] (II) Using input driver 'evdev' for 'HID 046a:0023'
[  1403.755] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  1403.755] (**) HID 046a:0023: always reports core events
[  1403.755] (**) evdev: HID 046a:0023: Device: "/dev/input/event4"
[  1403.755] (--) evdev: HID 046a:0023: Vendor 0x46a Product 0x23
[  1403.755] (--) evdev: HID 046a:0023: Found 1 mouse buttons
[  1403.755] (--) evdev: HID 046a:0023: Found scroll wheel(s)
[  1403.755] (--) evdev: HID 046a:0023: Found relative axes
[  1403.755] (II) evdev: HID 046a:0023: Forcing relative x/y axes to exist.
[  1403.755] (--) evdev: HID 046a:0023: Found absolute axes
[  1403.755] (II) evdev: HID 046a:0023: Forcing absolute x/y axes to exist.
[  1403.755] (--) evdev: HID 046a:0023: Found keys
[  1403.756] (II) evdev: HID 046a:0023: Configuring as mouse
[  1403.756] (II) evdev: HID 046a:0023: Configuring as keyboard
[  1403.756] (II) evdev: HID 046a:0023: Adding scrollwheel support
[  1403.756] (**) evdev: HID 046a:0023: YAxisMapping: buttons 4 and 5
[  1403.756] (**) evdev: HID 046a:0023: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  1403.756] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:02.1/usb1/1-9/1-9.4/1-9.4:1.1/input/input4/event4"
[  1403.756] (II) XINPUT: Adding extended input device "HID 046a:0023" (type: KEYBOARD, id 11)
[  1403.756] (**) Option "xkb_rules" "evdev"
[  1403.756] (**) Option "xkb_model" "pc105"
[  1403.756] (**) Option "xkb_layout" "de"
[  1403.756] (II) evdev: HID 046a:0023: initialized for relative axes.
[  1403.756] (WW) evdev: HID 046a:0023: ignoring absolute axes.
[  1403.756] (**) HID 046a:0023: (accel) keeping acceleration scheme 1
[  1403.756] (**) HID 046a:0023: (accel) acceleration profile 0
[  1403.756] (**) HID 046a:0023: (accel) acceleration factor: 2.000
[  1403.756] (**) HID 046a:0023: (accel) acceleration threshold: 4
[  1403.757] (II) config/udev: Adding input device HDA NVidia Line-Out Side (/dev/input/event10)
[  1403.757] (II) No input driver specified, ignoring this device.
[  1403.757] (II) This device may have been added with another device file.
[  1403.757] (II) config/udev: Adding input device HDA NVidia Line-Out CLFE (/dev/input/event11)
[  1403.757] (II) No input driver specified, ignoring this device.
[  1403.757] (II) This device may have been added with another device file.
[  1403.757] (II) config/udev: Adding input device HDA NVidia Line-Out Surround (/dev/input/event12)
[  1403.757] (II) No input driver specified, ignoring this device.
[  1403.757] (II) This device may have been added with another device file.
[  1403.758] (II) config/udev: Adding input device HDA NVidia Line-Out Front (/dev/input/event13)
[  1403.758] (II) No input driver specified, ignoring this device.
[  1403.758] (II) This device may have been added with another device file.
[  1403.758] (II) config/udev: Adding input device HDA NVidia Line (/dev/input/event6)
[  1403.758] (II) No input driver specified, ignoring this device.
[  1403.758] (II) This device may have been added with another device file.
[  1403.758] (II) config/udev: Adding input device HDA NVidia Front Mic (/dev/input/event7)
[  1403.758] (II) No input driver specified, ignoring this device.
[  1403.758] (II) This device may have been added with another device file.
[  1403.759] (II) config/udev: Adding input device HDA NVidia Rear Mic (/dev/input/event8)
[  1403.759] (II) No input driver specified, ignoring this device.
[  1403.759] (II) This device may have been added with another device file.
[  1403.759] (II) config/udev: Adding input device HDA NVidia Front Headphone (/dev/input/event9)
[  1403.759] (II) No input driver specified, ignoring this device.
[  1403.759] (II) This device may have been added with another device file.
[  1403.759] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=9 (/dev/input/event14)
[  1403.759] (II) No input driver specified, ignoring this device.
[  1403.759] (II) This device may have been added with another device file.
[  1403.760] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event15)
[  1403.760] (II) No input driver specified, ignoring this device.
[  1403.760] (II) This device may have been added with another device file.
[  1403.760] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event16)
[  1403.760] (II) No input driver specified, ignoring this device.
[  1403.760] (II) This device may have been added with another device file.
[  1403.760] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event17)
[  1403.760] (II) No input driver specified, ignoring this device.
[  1403.760] (II) This device may have been added with another device file.

Here is the xlog without the switch (verbose = 5) http://pastebin.com/UCAJZLpj

Getting the EDID manually, using get-edid, fails with:

get-edid: get-edid version 2.0.0

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
    Function supported
    Call successful

    VBE version 300
    VBE string at 0x2110 "NVIDIA"

VBE/DDC service about to be called
    Report DDC capabilities

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
    Function supported
    Call successful

    Monitor and video card combination does not support DDC1 transfers
    Monitor and video card combination does not support DDC2 transfers
    0 seconds per 128 byte EDID block transfer
    Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
    Read EDID

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
    Function supported
    Call failed

The EDID data should not be trusted as the VBE call failed
Error: output block unchanged
fredo@desktopAW:~$ sudo get-edid > temp/get-edid.log2
get-edid: get-edid version 2.0.0

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
    Function supported
    Call successful

    VBE version 300
    VBE string at 0x2110 "NVIDIA"

VBE/DDC service about to be called
    Report DDC capabilities

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
    Function supported
    Call successful

    Monitor and video card combination does not support DDC1 transfers
    Monitor and video card combination does not support DDC2 transfers
    0 seconds per 128 byte EDID block transfer
    Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
    Read EDID

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
    Function supported
    Call failed

The EDID data should not be trusted as the VBE call failed
Error: output block unchanged

And nvidia-settings complains:

The NVIDIA X driver on desktopAW:0.0 is not new
enough to support the nvidia-settings Display Configuration page.

Any help is greatly appreciated. Thank you

share|improve this question

3 Answers 3

As it turns out, this might be a bug after all. My X server ignores every configuration made in the standard xorg.conf. Instead, it only accepts configuration in the /usr/share/X11/xorg.conf.d/*.conf files, but only in the files already present. Therefore I hijacked one of the already existing configuration files. I know that an update will eventually overwrite them at some point in the future. To solve the initial issue, I used a custom modeline:

Section "Screen"
    Identifier "My Screen"
    Device "My Card"
    Monitor "SL23T-1 LED"
    Option "RegistryDwords" "EnableBrightnessControl=1"
    Option "UseEdid" "False"
    Option "CustomEdid" "CRT-1:/etc/X11/nvidia_edid.bin"
    Option "ExactModeTimingsDVI" "True"
    Option "ModeDebug" "True"
    DefaultDepth    24
    SubSection     "Display"
               Depth       24
               Modes      "1920x1080"
    EndSubSection

EndSection

Section "Device"
    Identifier "My Card"
    Driver "nvidia"
    Option "NoLogo" "True"
EndSection

Section "Monitor"
    Identifier "SL23T-1 LED"
    VendorName "FUS"
    ModelName "SL23T-1 LED"
    # Block type: 2:0 3:fd
    HorizSync 67.5 - 67.5
    VertRefresh 60.0

    ModeLine "1920x1080" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    Option   "DPMS"

EndSection
share|improve this answer

I had a similar problem but I use HDMI. The resolution was always done with nvidia auto.

It seems the problem is out dated drivers from additional drivers you can get the very latest from the following PPA.

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates 
sudo apt-get update
sudo apt-get dist upgrade

This might fix your problem.

share|improve this answer
    
Unfortunately this didn't work. The new drivers cant query the EDID at all. Here is a link to the xlog link –  fvclaus Sep 15 '12 at 13:22

What i did (on 14.04) after pulling my hair out over this (Google shows a LOT of hits about older versions of Ubuntu, but nothing about newer ones) was ignore the Xorg.conf stuff altogether. Instead, i enabled automatic logon, and put the following in my .xprofile:

xrandr --fb 1920x1080
xrandr --newmode "1920x1080_59.9" 138.5 1920 1968 2000 2080 1080 1083 1088 1111 +HSync -VSync
xrandr --addmode VGA1 "1920x1080_59.9"
xrandr --output VGA1 --mode 1920x1080_59.9

I got the parameters of newmode by using cvt -r 1920 1080. If you have a chance to turn on DDC for a while (for example, your KVM switch doesn't handle DDC, but you can plug the monitor directly into the video card to debug), you can use xrandr --verbose -q as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.