Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've seen similar problems to this several times in the forum, but mine is a bit different, so the other posts I saw were no help to me.

When I boot Ubuntu 12.04 64-bit from live-SD-card (3GB persistence) I suddenly get this error:

(initramfs) mount: mounting /dev/loop0 on //filesystem.squashfs failed: Invalid argument

Can not mount /dev/loop/0 (/cdrom/casper/filesystem.squashfs) on //filesystem.squashfs

(it says I can type "help" for commands, but I don't know anything about how to go from there, totally new to Linux)

The reason I say my case is different is because my Ubuntu worked fine for over a week, even pretty fast, and now this problem happened. Before that I used to run my live Ubuntu from USB sticks but that was slower (especially when booting which took 15 minutes from USB stick!). Also I kept getting the same above problem after a while when booting and had to re-create a live USB several times.

Installing on harddrive is not an option because my harddrive has physically damaged and getting a replacement will take a while, therefore I can only use Live-USB or live-SD-card Ubuntu.

As I said I used Ubuntu without problems for more than a week, before that as well for several weeks on USB sticks, but the above problem occurred sooner or later. This time I paid attention to when it happened:

I was rebooting my computer (HP 620 laptop, 4 GB RAM, 64 bit system) from SD flash card and when I was booting I selected F6 and then the first option "no acpi" or something like that...I had used it before and noticed it slowed down the time it took Linux to use. This time it caused this error.

Now even when I boot normally/default I get this error.

Now I'm accessing Ubuntu from my USB stick without persistence file, when I check my SD card, all the files mentioned in the error message are there and the filesystem.squashfs is 691.2 MB so nothing seems to have been deleted by accident.

(I have already made many changes/downloaded programs to my SD card persistent Ubuntu and don't want to loose them, since downloading is expensive for me, and since the problem seems to re-occur...)

Can anyone help me, preferably without having to create another startup disk on my SD card? I'm totally new to this.

Sorry for the long posts, just didn't know what info is relevant and what isn't!

share|improve this question
    
Welcome to Ask Ubuntu! Don't be sorry for long post. Ask Ubuntu site is for Ubuntu users with short, long and medium post. Hope someone will take your problem and provide some help to you. –  Anwar Shah Sep 15 '12 at 10:21

1 Answer 1

It sounds like you may have filled casper-rw and used up your persistence. This can happen trying to do an update on a small drive. You can access casper-rw, from a running copy of Ubuntu, and recover files thus:

sudo mkdir /media/casper

then

sudo mount -o loop casper-rw /media/casper/
share|improve this answer
    
Hey Cam, thx for replying... When I type the second line "sudo mount" etc I get this: "casper-rw: No such file or directory" How do I even know if I am accessing the casper folder on the USB stick Im running Ubuntu from or from the SD card that Im trying to fix?! :/ I know absolutely nothing about the terminal... also i dont think I ran out of space, because I had a 3GB persistence file and I didnt use more than 500MB... When i access my SD card and go to the casper folder, the filesystem.squashfs file is 691.2MB, so within the limits of the persistence file!? –  user89743 Sep 15 '12 at 17:09
    
You may need to include the path to casper-rw, for me it is: –  C.S.Cameron Sep 15 '12 at 20:43
    
sudo mount -o loop /media/UBUNTULIVE/casper-rw /media/casper/ –  C.S.Cameron Sep 15 '12 at 20:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.