Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I press Alt + Tab , Unity moves the window I'm switching to so that the whole window is inside the screen. This behavior is excruciatingly annoying because I often move a window (usually text editors) partially outside the current screen so I can view another window below it (usually a browser). Every time I Alt + Tab back to the text editor, I'm getting an unnecessary virtual screen switch, and Unity is rearranging the windows behind my back.

For instance, here is a browser and text editor on Virtual Screen 1 (top left), note that the text editor is partially outside the current screen:

enter image description here

Then I Alt-Tab to the browser (or clicked on it):

enter image description here

Next, I Alt + Tab again to get back to the text editor, but Alt-Tab switched me to Virtual Screen 4 (bottom right) because a larger percentage of the text editor window is on virtual screen 4 than in virtual screen 1; and the browser is no longer in the screen. Also note that the text editor window moves from being on the bottom-right to the top-left, which is very disorienting as I can no longer keep track of where any of my windows are since they all keep moving around by themselves..

enter image description here

How do I disable this behavior? I don't want to have any virtual screen switch when Alt + Tab , especially since Alt + Tab does not list windows that is completely not in the current virtual screen anyway.

share|improve this question
    
I've got the same problem. Actually this behavior happens in many cases. I use multiple workspaces and when I go to another workspace, windows move at times being sent to another workspace. I just need to strangle someone right now! Worst of all, when I move my mouse it gives focus to the window under the pointer. Bing! The window I just moved out of the way is right back where I didn't want it. That's just crazy! –  Alexis Wilke Oct 18 '12 at 0:30
    
add comment

1 Answer

I believe the solution you want is to tell the compiz place plugin to ignore the window in question. You can edit the compiz plugin settings with gconf-editor, however you will need to install it first.

Personally I prefer to leave compiz and it's plugins alone and run with the defaults - I've spent too much time fixing a broken system.

Another solution that seems to suggest itself is to disable the place plugin completely, however this may prove to be even more annoying since all of the automatic window placment we take for granted will be missing. New windows will always open at 0,0 for example, probably being put under the launcher and top panel.

If I want a windowed application to be on the screen at the same time as another application it's a fairly simple matter to resize the windows and place them appropriately. With a high resolution desktop it's possible to increase productivity significantly if you re-size the windows and change the placement, while keeping them entirely on the current desktop.

share|improve this answer
    
I'm on a 13 inch laptop, a pretty standard size, changing to a higher screen resolution is not an option. I normally don't have my text editor at that size (it's enlarged for demonstration), usually my editor is about a quarter of the screen. While editing HTML, I constantly switch back and forth between editor and the browser, and resizing the browser down would not be an option as that would trigger the mobile layout. Therefore the only option is to keep the editor on top of the browser and put it to the side when I need to take a closer look on the browser. –  Lie Ryan Sep 15 '12 at 11:17
    
This autonomous screen switching therefore is really interrupting to my workflow. I'll check out the compiz place plugin as you suggested. No other window manager I've used exhibits this behavior, not on compiz on non Ubuntu, and not even on older Ubuntu. No other window manager had the nerve to move around when they're not told to. –  Lie Ryan Sep 15 '12 at 11:18
    
Nope, it's not the place plugin. Even when disabled it's still exhibiting the same behaviour. What's worse is that even if I disabled unity plugin's alt-tab and used another application switcher plugin, this behavior still persists. –  Lie Ryan Sep 15 '12 at 11:59
    
Have you tried rebooting? While I was reading about this I came across a reference to the disable needing a reboot to take effect –  fabricator4 Sep 15 '12 at 12:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.