Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently bought humble bundle 2 ( http://www.humblebundle.com/ ). Is there a way to run Braid using ATI's open-source drivers? The game always crashes. When do get it to start in windowed mode once i go to the first level it will crash. I am using the lastest version of Braid (ST3C ignored)

When I use the proprietary drivers Braid works flawlessly and World of Goo performance is increased. However there is terrible screen tearing with the ATI propritary drivers.

So my question is: How do I play Braid if I want to use the proprietary drivers?

share|improve this question
    
First let me thank you for being another user that helps humblebundle. I too help them. +1 to you. For the Ati question i can not help since am 100% Nvidia. Sorry buddy. –  Luis Dec 25 '10 at 7:05
    
I have the same problem. Went through some loops to make it start at all. Maybe the newer Xorg drivers from Natty Narwhal might help. Or you could try to toy with settings in driconf. –  mario Dec 25 '10 at 13:36

3 Answers 3

Did you try to turn off desktop effects while you play? I saw on forums that compiz may cause flickering of video while on.

share|improve this answer
2  
Compiz can cause when playing any OpenGL game: 1. Flickering 2. Resolution Mixing (Resolution from Game mixes with Desktop) 3. Less FPS 4. Alpha Effects (While playing you see the Desktop) 5. Mouse Problems 6. Gamma / Contrast Problems So yes, you NEED to turn if off if you want to play something. Does not matter if you have an NVIDIA 1000000 with 2TB of RAM. Turn it off when you want to play. –  Luis Dec 25 '10 at 10:15
    
Conversely, I never turn it off and I've never had any problems with any of the Humble Bundle games (1 or 2), or Defcom. That said, I'm using either Intel, or Nvidia-proprietary, not ATI. Given the number of recommendations to turn off Compiz while playing games, I think I've just been lucky. –  Scaine Dec 25 '10 at 12:29

Try Alt + F2 and metacity --replace before you play and game and use Alt +F2 and compiz --replace after the game.

share|improve this answer

1. Consider switching to LXDE or KDE desktop environment

I think you should seriously consider switching to Lubuntu. Compiz is bollocks and it will remain so at least to late 2013. That's if you believe it will -ever- do less harm than good, that is. Please note that you can install LXDE on regular Unity Ubuntu and choose your desktop environment at login! (session)
LXDE also affects gaming performance?

If I install any dekstop environment (like XFCE) alongside Unity can it affect Unity?

2. Re-consider your choice to use open-source ATI drivers

They are usually 3 times (yup, 300%) slower than the proprietary ones.
See:
How to review the current state of open source vs. closed source graphics drivers?

If you have ATI/Intel hybrid (switchable) graphics: You can use your Intel for desktop and ATI for gaming. Switching on Linux is cumbersome for older generation hybrids though
How to re-configure graphics from Intel integrated to Intel / ATI switchable?

As for the bug you experience:
Intel vs AMD desktop performance - worse on AMD
Catalyst Tear Free option requires over 256 MB video RAM

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.