Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My NTFS partition is mounted as follows:

/dev/sdb1 /mnt/dos ntfs permissions,locale=en_US.utf8,uid=1000,umask=0 0 0

I bound several folders to my home as follows:

/mnt/dos/Books /home/me/Books none bind 0 0
/mnt/dos/Music /home/me/Music none bind 0 0
/mnt/dos/Videos /home/me/Videos none bind 0 0
/mnt/dos/Pictures /home/me/Pictures none bind 0 0

Whenever a file is deleted in Nautilus from these bound folders it gets sent to the .Trash-1000 located under the bound folder rather than the one in my home directory. I do not see the contents of these additional trash folders when I click on the Trash icon, so they are practically inaccessible. I do not believe this is the intended behavior.

FYI: Unresolved thread on ubuntuforums.

share|improve this question
rm never moves files to Trash. What heppen when you want to delete? – Anwar Shah Sep 15 '12 at 4:38

Add umask=0 at the end of mount-options line. I've tested it with ntfs partition in my PC. It should make nautilus delete folder to .Trash-1000 folder.

The line should now becomes like this

/dev/sdb1 /mnt/dos ntfs permissions,locale=en_US.utf8,uid=1000,umask=0  0 0

Replace the uid=1000 with the original uid of your user. You can see it by using id -u command.

share|improve this answer
This gives me a "Cannot move file to trash, do you want to delete immediately?" error. What are your Trash folder's permissions and groups? Mine are all root. – Emre Sep 15 '12 at 7:56
My .Trash-1000 folder's owner is Me (uid=1000) – Anwar Shah Sep 15 '12 at 7:58
@Emre also add the actual uid before umask by using uid=XXXX format. for me it is uid=1000 – Anwar Shah Sep 15 '12 at 8:03
That did not work. Something is still different between our configurations. Can you help me troubleshoot? – Emre Sep 15 '12 at 8:24
Let me know the output of your id -u and the line of /etc/fstab. ? – Anwar Shah Sep 15 '12 at 10:06
up vote 0 down vote accepted

This is a long-standing bug that, as of writing, has not been fixed.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.