Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Ubuntu does not put Fedora into GRUB menu

I have Windows XP Installed, and i have installed Fedora 15, yesterday. Updated it today to 17, and installed Ubuntu. After installing ubuntu, it messed up the grub. Grub wont find fedora anymore. I have tried booting from the Live CD, and installing Boot-Repair. It find a Raid unit, asks for mdadm. Tried with mdadm, and withoud dmraid. No progress. When i go to my files, in the live cd, the fedora unit shows up. What have i done wrong? haha I think, it's something about this raid unit.

share|improve this question

migrated from unix.stackexchange.com Sep 15 '12 at 0:34

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems..

marked as duplicate by jrg Sep 15 '12 at 1:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

up vote 1 down vote accepted

Check if the os-prober package is installed in Ubuntu with dpkg -l os-prober.

If it isn't installed, then:

sudo apt-get install os-prober
sudo update-grub

BTW, Ubuntu 12.04 does some horrible things to the grub menu with /etc/default/grub. You might want to edit it to comment out these lines:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true

and add these in their place:

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
GRUB_TIMEOUT=5

This will stop the grub menu from being hidden at boot and will make whatever you choose from the menu be the next default. It also allows grub-set-default and grub-reboot to work (they don't when GRUB_DEFAULT is hard-coded to 0).

Don't forget to run sudo update-grub after editing it, and then sudo grub-set-default 0 to make sure it has a sane default.

Also, if you don't like the submenu that it hides old kernels with, then patch /etc/grub.d/10_linux like this:

--- 10_linux.orig       2012-05-17 07:07:17.000000000 +0000
+++ 10_linux    2012-08-27 03:46:54.803088897 +0000
@@ -254,12 +254,12 @@

   list=`echo $list | tr ' ' '\n' | grep -vx $linux | tr '\n' ' '`

-  if [ "$list" ] && ! $in_submenu; then
-    echo "submenu \"Previous Linux versions\" {"
-    in_submenu=:
-  fi
 done

-if $in_submenu; then
-  echo "}"
-fi

and, again, run sudo update-grub.

share|improve this answer
    
I already have os-prober instlled. I've made everything you told me, and another thing i read in a forum. I've added this: #!/bin/sh cat << \EOF menuentry "Fedora" { set root=(hd0,3) chainloader +1 } EOF to /etc/grub.d/17_fedora and now, it shows up on grub. My fedora partition is on /dev/sda3, as lmv2 file system. –  ghaschel Sep 15 '12 at 0:13
    
All i get in the grub menu, is ` error: invalid signature` I have read somewhere, that Grub don`t allow you to add fedora to its menus, because of the Raid partition, and what must be done, is linking Grub with the fedora default's grub. Can someone please help me? :P –  ghaschel Sep 15 '12 at 0:14
    
grub's disk and partition numbering is zero-based, so (hd0,3) refers to /dev/sda4, not /dev/sda3. Try (hd0,2) instead. –  cas Sep 15 '12 at 0:19
    
Nope, it still shows: error: invalid signature –  ghaschel Sep 15 '12 at 0:27
    
before restarting, i updated grub –  ghaschel Sep 15 '12 at 0:28
show 3 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.