Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Bluetooth device disappeared after I changed its mode from High Fidelity A2DP to off. Is this a bug? How can I get my speaker back into the audio menu?

I tried disconnecting and reconnecting. But it seems that Ubuntu remembers the Bluetooth setting and leaves it off.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I've experienced this too, though it was not in the 'off' profile, but telephony profile for some reason.

Try installing pavucontrol, start it up (PulseAudio Volume Control), and reselect the A2DP profile used for your audio device there in the tab 'Configuration'. It should remember the profile the next time you plug in (or connect for Bluetooth).

Screenshot of pavucontrol for A2DP profile selection.

For a command-line way of doing this, try

BLUEZCARD=`pactl list cards short | egrep -o bluez.*[[:space:]]`
pactl set-card-profile $BLUEZCARD a2dp

As can be found in this answer (by @izx).

share|improve this answer
    
Thank you so much! I'm really new into this Linux Stuff and it seems that device Management is really painful on Ubuntu if you come from a PC. I can't understand why the normal Audio Control has so less options. But Anyhow. You are my hero! I would flipped out without you. Thank you again! :) –  Mete Tüfekci Sep 14 '12 at 23:50
    
That sound menu, should bring you to the full fledged Sound software, you should have the option there. –  Uri Herrera Sep 14 '12 at 23:59
    
@UriHerrera From the question: "my Bluetooth Device disapeared". Therefore I guess it breaks for him, supposedly. pavucontrol is just an alternative GUI to make Pulseaudio/bluez apply this profile change. –  gertvdijk Sep 15 '12 at 0:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.