Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got three partitions at installation of Ubuntu 12.04, whose mount points are:


But I needed a partition so I merged /usr/local by copying all its contents into a folder named local2. Then I dismounted and formatted partition of /usr/local, and then I moved the folder local2 to /usr/local.

Ubuntu seems to work fine, but when I turn on PC, Ubuntu start screen says (more or less):

/usr/local partition not found. Press S to skip or M to mount it manually.

How can I fix this?

share|improve this question

Edit /etc/fstab (as root) -- remove the line that refers to /usr/local.

share|improve this answer

Open the terminal and type:

gksudo gedit /etc/fstab

Look for the line that points to /usr/local. You probably have that partition set to auto-mount if you specified "defaults" as an option. When partitions are auto-mounted on boot, Ubuntu will check and try to mount it on boot, but since you formatted the said partition, it's UUID have changed and therefore Ubuntu cannot find it on boot.

You just need to edit the UUID of the /usr/local partition. You can check the UUID by running:

sudo blkid

Once you have the UUID, just copy it and replace the UUID on the line that points to /usr/local.

share|improve this answer
No, since the user did not move /usr/local to another partition -- the user just moved it to the root partition. There is no need of mounting at all, removing the line from fstab should be fine. – January Sep 15 '12 at 13:43
But the OP said he/she formatted the /usr/local partition, by then the UUID would have changed. That's what I think. – Peachy Sep 15 '12 at 13:46
Yes, but it is no longer /usr/local. The system works, local is available, but the stale entry in the fstab causes an error message. – January Sep 15 '12 at 14:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.